Bug 164623 - Firefox font rendering looks uneven
Firefox font rendering looks uneven
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: FIREFOX_PANGO
  Show dependency treegraph
 
Reported: 2005-07-29 09:45 EDT by Dennis Jacobfeuerborn
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 06:29:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rendering comparison: left=Rawhide, right=current mozilla.org nightly (65.33 KB, image/png)
2005-07-29 09:45 EDT, Dennis Jacobfeuerborn
no flags Details

  None (edit)
Description Dennis Jacobfeuerborn 2005-07-29 09:45:39 EDT
Description of problem:
The font rendering in Rawhides Firefox looks very uneven and "ugly" when
compared to the current nightly build from mozilla.org. (see attached screenshot)

Version-Release number of selected component (if applicable):
firefox-1.1-0.2.4.deerpark.alpha2

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dennis Jacobfeuerborn 2005-07-29 09:45:39 EDT
Created attachment 117272 [details]
rendering comparison: left=Rawhide, right=current mozilla.org nightly
Comment 2 Bill Nottingham 2005-07-29 20:12:51 EDT
What versions of pango and cairo do you have installed?
Comment 3 Dennis Jacobfeuerborn 2005-07-30 10:51:08 EDT
pango-1.9.1-1
cairo-0.6.0-1

but the rendering looked the same with the versions before the last Rawhide
update of these packages.
Comment 4 Dennis Jacobfeuerborn 2005-07-30 11:03:49 EDT
For the record: Disabling Pango in /usr/bin/firefox by uncommenting the
following lines (as mentioned in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=164664 ) makes the
font-rendering look fine again.

---
##
## Set MOZ_ENABLE_PANGO is no longer used because Pango is enabled by default
## you may use MOZ_DISABLE_PANGO=1 to force disabling of pango
##
MOZ_DISABLE_PANGO=1
export MOZ_DISABLE_PANGO
---
Comment 5 Dennis Jacobfeuerborn 2005-08-03 08:55:50 EDT
Now that bug 164664 is fixed i was able to use firefox with pango enabled for a
while and noticed that the problem on appears with serif fonts while sans-serif
fonts are displayed correctly.
Comment 6 Parag Nemade 2007-10-01 06:29:43 EDT
Very old Bug. Closing this for now as we already got new updated firefox in
rawhide now. Kindly submit bugs against new rawhide version.

Note You need to log in before you can comment on or make changes to this bug.