Bug 1646568 - initial-setup hangs during boot after IoT installation
Summary: initial-setup hangs during boot after IoT installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-simpleline
Version: 29
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jiri Konecny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: IoT
TreeView+ depends on / blocked
 
Reported: 2018-11-05 16:49 UTC by Paul Whalen
Modified: 2018-11-22 03:20 UTC (History)
11 users (show)

Fixed In Version: python-simpleline-1.4-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-22 03:20:45 UTC


Attachments (Terms of Use)
initial-setup logs (24.24 KB, text/plain)
2018-11-05 16:49 UTC, Paul Whalen
no flags Details
journalctl (475.69 KB, text/plain)
2018-11-05 16:51 UTC, Paul Whalen
no flags Details

Description Paul Whalen 2018-11-05 16:49:57 UTC
Created attachment 1502035 [details]
initial-setup logs

Description of problem:
After installing Fedora IoT, the system hangs at boot waiting for initial-setup, even when a user already exists and root password has been set during the installation. 

Version-Release number of selected component (if applicable):
initial-setup-0.3.62-1.fc29.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install IoT edition
2. reboot, boot will hang

Comment 1 Paul Whalen 2018-11-05 16:51:09 UTC
Created attachment 1502036 [details]
journalctl

Comment 2 Paul Whalen 2018-11-06 15:13:02 UTC
Testing todays IoT compose with python3-3.7.1-2.fc29 and initial-setup-0.3.62-1.fc29, the boot still hangs waiting for initial-setup.

Comment 3 Peter Robinson 2018-11-06 15:23:04 UTC
The 2018-11-06 IoT compose pulled in python3-3.7.1-2.fc29 as referenced in 1160259 as a possible fix to no effect.

Looking at the anaconda-ks.cfg generated during install it's got the following line:
# Run the Setup Agent on first boot
firstboot --enable

Which I don't believe should be there given that that the root password is set during install, and a user is created so the firstboot option should not be required.

Comment 4 Troy Dawson 2018-11-14 22:46:46 UTC
Either this is fixed or I'm having a hard time reproducing this.
I've tried with both x86_64 (VM) and aarch64 (RPI3).  It boots correctly and I am able to use the firstboot to generate a user.
I am using the images
Fedora-IoT-29-20181114.0.aarch64.raw.xz
Fedora-IoT-29-20181114.0.x86_64.raw.xz

Comment 5 Martin Kolman 2018-11-15 09:08:53 UTC
(In reply to Troy Dawson from comment #4)
> Either this is fixed or I'm having a hard time reproducing this.
> I've tried with both x86_64 (VM) and aarch64 (RPI3).  It boots correctly and
> I am able to use the firstboot to generate a user.
> I am using the images
> Fedora-IoT-29-20181114.0.aarch64.raw.xz
> Fedora-IoT-29-20181114.0.x86_64.raw.xz
My testing indictaes all works fine (Initial Setup TUI shows up and can be used) if user is *not* created during the installation. But when user *is* created during the installation and Initial Setup is enabled, instead of Initial Setup detecting there is nothing for it to do it get's stuck for some reason.

Comment 6 Martin Kolman 2018-11-16 17:28:04 UTC
Turns out this is caused by the text interface starting the TUI main loop even if no screens are scheduled to be shown. 

This happens in this case, as user has already been created so there is nothing to be shown, but the main loop will still be started, effectively waiting forever.

As the parent TUI classes that handle the main loop startup are in Anaconda and Initial Setup only inherits them I'm reassigning this bug to Anaconda as the fix will have to go there.

Comment 7 Martin Kolman 2018-11-16 17:41:23 UTC
PR: https://github.com/rhinstaller/anaconda/pull/1692

Comment 8 Jiri Konecny 2018-11-19 14:25:43 UTC
We found a better solution in the python-simpleline project. That is used for the text user interface in the Initial Setup and Anaconda.

Comment 9 Jiri Konecny 2018-11-19 14:26:09 UTC
PR: https://github.com/rhinstaller/python-simpleline/pull/59

Comment 10 Fedora Update System 2018-11-19 16:26:04 UTC
initial-setup-0.3.62-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-f9bf4608fa

Comment 11 Fedora Update System 2018-11-20 17:02:15 UTC
initial-setup-0.3.62-2.fc29, python-simpleline-1.4-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-f9bf4608fa

Comment 12 Paul Whalen 2018-11-21 15:32:31 UTC
Working in initial-setup-0.3.62-2.fc29, thanks Martin!

Comment 13 Fedora Update System 2018-11-22 03:20:45 UTC
initial-setup-0.3.62-2.fc29, python-simpleline-1.4-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.