Bug 1646728 - [snapview-server]:forget glfs handles during inode forget
Summary: [snapview-server]:forget glfs handles during inode forget
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-05 22:16 UTC by Raghavendra Bhat
Modified: 2019-03-25 16:31 UTC (History)
1 user (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 16:31:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 21564 None Merged snapview-server: close the gfapi handle present in a forgotten inode 2018-11-20 11:22:12 UTC

Description Raghavendra Bhat 2018-11-05 22:16:31 UTC
Description of problem:

   Currently, the snapdaemon can reach the lru limit of the inode table
    and start sending forgets on the inodes that are least recently used.
    snapview-server maintains the mapping between the domain of the
    snapdaemon and the gfapi instance which it uses to access the snapshots
    via a handle that is stored in the inode context of snapdaemon's inode.
    The handle is glfs_h_object structure which itself points to the actual
    inode present in the gfapi world.
    
    But, when snapview-server receives forget on a inode, it deleted the
    inode context without actually closing the handle it had obtained to
    map the inode from snapdaemon to the inode in gfapi world.
    

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-11-05 22:20:41 UTC
REVIEW: https://review.gluster.org/21564 (snapview-server: close the gfapi handle present in a forgotten inode) posted (#1) for review on master by Raghavendra Bhat

Comment 2 Worker Ant 2018-11-20 11:22:11 UTC
REVIEW: https://review.gluster.org/21564 (snapview-server: close the gfapi handle present in a forgotten inode) posted (#2) for review on master by mohammed rafi  kc

Comment 3 Shyamsundar 2019-03-25 16:31:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.