Bug 1646740 - Non admin user is unable to see the audits for katello and taxable resources created by admin using Any Location context
Summary: Non admin user is unable to see the audits for katello and taxable resources ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Audit Log
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: 6.4.1
Assignee: satellite6-bugs
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-05 22:50 UTC by Mike McCune
Modified: 2019-10-30 19:38 UTC (History)
7 users (show)

Fixed In Version: foreman-1.18.0.39-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1600095
Environment:
Last Closed: 2018-12-06 22:32:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
verification video (890.32 KB, application/octet-stream)
2018-11-21 20:49 UTC, jcallaha
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 24232 None None None 2018-11-05 22:50:03 UTC
Red Hat Product Errata RHBA-2018:3799 None None None 2018-12-06 22:33:26 UTC

Comment 2 jcallaha 2018-11-21 20:49:58 UTC
Created attachment 1507817 [details]
verification video

Followed the reproducer steps.

While the new user is able to see audits, they are also able to see audits outside their organization.

Comment 8 errata-xmlrpc 2018-12-06 22:32:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3799


Note You need to log in before you can comment on or make changes to this bug.