Bug 1646742 - [Satellite 6.2.14] Config group is not working with customer user role. (Failing with Stack level too deep)
Summary: [Satellite 6.2.14] Config group is not working with customer user role. (Fail...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles
Version: 6.2.12
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: 6.4.1
Assignee: satellite6-bugs
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks: 1541321
TreeView+ depends on / blocked
 
Reported: 2018-11-05 22:50 UTC by Mike McCune
Modified: 2019-10-30 19:38 UTC (History)
7 users (show)

Fixed In Version: foreman-1.18.0.39-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1560672
Environment:
Last Closed: 2018-12-06 22:32:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
verification video (1.10 MB, application/octet-stream)
2018-11-21 19:44 UTC, jcallaha
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 23951 None None None 2018-11-05 22:50:42 UTC
Red Hat Product Errata RHBA-2018:3799 None None None 2018-12-06 22:33:26 UTC

Comment 3 jcallaha 2018-11-21 19:44:09 UTC
Verified in Satellite 6.4.1 Snap 1.

Following the reproducer steps, no issues were encountered while viewing hosts as the new user. See attached video for verification.

Comment 4 jcallaha 2018-11-21 19:44:27 UTC
Created attachment 1507800 [details]
verification video

Comment 6 errata-xmlrpc 2018-12-06 22:32:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3799

Comment 7 Mike McCune 2018-12-10 16:05:44 UTC
Description of problem:

Created a role and set Resource type = Host and Search = Config Group. Assign this role to the user and login with the user which is using this customized role. Go to Hosts page, it shows error = Stack level too deep. 

How reproducible:
Always

Steps to Reproduce:

1. Create a config group.

2.Add a role with resource type = Content Host, Host, Host Collection, Location and Host with config_group (Refer Image = 6.2.12.Customers_Filter-1.png)
 
3. and log in with that user and go to Hosts page in the satellite. We will get Stack level too deep error.

Actual results:

Facing issue = Stack level too deep error

Expected results:
User should be able to view the all hosts page in satellite.

Additional info:
We have reproduced same on 6.2.12, 6.2.13 and 6.3.0 and we are getting the same error.  While reproducing the issue we added some more resource types just confirm the permission details but we got the same error.


Note You need to log in before you can comment on or make changes to this bug.