Bug 164679 - Unable to synchronise with desktop
Unable to synchronise with desktop
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: jpilot (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-29 18:52 EDT by Martin Burchell
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-07 03:12:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Burchell 2005-07-29 18:52:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Unable to synchronise Palm Vx with desktop over serial port

Version-Release number of selected component (if applicable):
jpilot-0.99.8-0.pre9.fc4.1

How reproducible:
Always

Steps to Reproduce:
1.Press hot-sync button on JPilot
2.Press hot-sync button on Palm
3.
  

Actual Results:  Error message:

Last Synced Username-->"Martin"
Last Synced UserID-->"12345"
 This Username-->""
 This User ID-->151628184
Exiting with status SYNC_ERROR_NOT_SAME_USERID
Finished


Expected Results:  Synchronisation should have happened without the error.  My user ID and name have not been changed.


Additional info:

pilot-xfer works OK without any errors reported for UserID and Username

Seems to be a problem with pilot-link-0.12.0-0.pre3.0.fc4.1 and jpilot-0.99.8-0.pre9.fc4.1

This workaround seems to be working for me:
Erase pilot-link, pilot-link-devel and any dependencies (inc jpilot)
Install pilot-link-0.11.8-8 and pilot-link-devel-0.11.8-8 from FC3
Rebuild jpilot-0.99.8-0.pre9.fc4.1 from SRPM
Install jpilot-0.99.8-0.pre9.fc4.1
Comment 1 John McDonald 2005-08-05 10:34:07 EDT
I had the same problem with my PalmV. I tried a lot of different things that I
read from the web and none seemed to work. However I have finally got it to work
but I am not sure exactly how. From the web I read that one of the problems is
that the baud rate on the serial line can be set incorrectly. Initially on both
my Palm and in jpilot's preferences it was set to 57600. I read that setting it
to 9660 in jpilot's prefs would fix the problem. It didn't. Then I set it to
9660 on the Palm still with no success. Next I set it back to 57600 on both the
Palm and jpilot and hey presto it worked ?!?!?

I can't be sure that it was only the set of steps above that solved it but it is
worth a try. It could be that on upgrading to the FC4 packages the speed in the
code drops back to some default without changing the menu item. Changing the
speed to 9660 and then to 57600 maybe forces this setting to 57600. 

Apologies for so many "maybes" and "not sures" here but now that I have it
working I don't want to fiddle around with it too much for fear it will break again.

Be sure to post whether or not this fixed it.

Regards,
John McDonald.

PS One thing that could be important is that if when the original error pops up
you choose to "sync anyway" the username and uid in .jpilot/jpilot.rc is changed
to the random value. Hence you may need to edit this file manually and reset it
to whatever is stored on the palm pilot.
Comment 2 Martin Burchell 2005-08-05 17:27:45 EDT
John,

I reinstalled the most recent packages and tried various flow rate changes both
in JPilot and on the device, as you suggested.  Unfortunately I still got the
same error message.  I'm quite happy with my workaround for the time being.
Comment 3 John McDonald 2005-08-10 11:08:15 EDT
Hi Martin,

Apologies for the late update. But it seems that my fix was not a fix but merely
some random event of sorts. The sync problem is back even though I have changed
nothing. Sorry for the confusion.

Comment 4 Ivana Varekova 2005-08-11 10:20:26 EDT
Hello, 
could you please try to reproduce this problem with the latest devel jpilot
version jpilot-0.99.8-0.pre10.1.
Comment 5 Adalbert Prokop 2005-08-12 11:55:03 EDT
(In reply to comment #4)
Hello 

I tried jpilot-0.99.8-0.pre10.1. Ufortunately the problem remains - no
synchronization is possible.

dlp_OpenConduit() failed
Exit-Status: SYNC_ERROR_OPEN_CONDUIT
Comment 6 Adalbert Prokop 2005-08-14 14:52:23 EDT
I've created RPM packages as workaround for this problem. pilot-link-118 is the
pilot-link package from FC3. It will install entirely into
/usr/lib/pilot-link-118 and can be installed together with pilot-link from FC4.
The JPilot package is compiled against those old pilot-link libs.

http://familie-prokop.de/jpilot.html
Comment 7 Martin Burchell 2005-10-06 18:18:52 EDT
Since upgrading the following packages I have managed to synchronise successfully:

jpilot-0.99.8-0.pre10.fc4.1
pilot-link-0.12.0-0.pre4.0.fc4.2
pilot-link-devel-0.12.0-0.pre4.0.fc4.2
Comment 8 Ivana Varekova 2005-10-07 03:12:13 EDT
Closing bug.

Note You need to log in before you can comment on or make changes to this bug.