Bug 1646818 (CVE-2018-16471) - CVE-2018-16471 rubygem-rack: Cross-site scripting (XSS) via `scheme` method on `Rack::Request`
Summary: CVE-2018-16471 rubygem-rack: Cross-site scripting (XSS) via `scheme` method o...
Status: NEW
Alias: CVE-2018-16471
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20181106,repor...
Keywords: Security
Depends On: 1646820 1654556 1646819 1655633 1655634 1658572
Blocks: 1646821
TreeView+ depends on / blocked
 
Reported: 2018-11-06 04:38 UTC by Sam Fowler
Modified: 2019-04-22 21:36 UTC (History)
60 users (show)

(edit)
Clone Of:
(edit)
Last Closed:


Attachments (Terms of Use)

Description Sam Fowler 2018-11-06 04:38:16 UTC
Rack (rubygem-rack) versions before 2.0.6 are vulnerable to a cross-site scripting (XSS) flaw via the `scheme` method on `Rack::Request`.


External Reference:

https://groups.google.com/d/msg/rubyonrails-security/GKsAFT924Ag/DYtk-Xl6AAAJ

Comment 1 Sam Fowler 2018-11-06 04:39:10 UTC
Created rubygem-rack tracking bugs for this issue:

Affects: epel-all [bug 1646820]
Affects: fedora-all [bug 1646819]

Comment 3 James Hebden 2018-11-29 06:22:29 UTC
Red Hat OpenStack Platform and OpenShift Enterprise are not affected. Whilst the version of rack in use as a dependency in optional components is vulnerable, the vulnerable variable is not used in a way that could lead to XSS.

Comment 7 Riccardo Schirone 2018-12-12 12:25:27 UTC
Upstream patches:
- https://github.com/rack/rack/commit/313dd6a05a5924ed6c82072299c53fed09e39ae7 (for 2.0-stable branch)
- https://github.com/rack/rack/commit/97ca63d87d88b4088fb1995b14103d4fe6a5e594 (for 1.6-stable branch)

Comment 11 Richard Maciel Costa 2019-01-04 22:37:32 UTC
Statement:

Red Hat OpenStack Platform and OpenShift Enterprise are not affected. Whilst the version of rack in use as a dependency in optional components is vulnerable, the vulnerable variable is not used in a way that could lead to XSS.

Subscription Asset Manager is now in a reduced support phase receiving only Critical impact security fixes. This issue has been rated as having a security impact Moderate, and is not currently planned to be addressed in future updates.

Red Hat CloudForms and Satellite 6 are not affected. Whilst the version of rack in use as a dependency in optional components is vulnerable, the vulnerable variable is not used in a way that could lead to XSS.


Note You need to log in before you can comment on or make changes to this bug.