Bug 1646834 - CSI hostpath driver liveness probe failed
Summary: CSI hostpath driver liveness probe failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.1.0
Assignee: Jan Safranek
QA Contact: Wenqi He
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-06 05:52 UTC by Wenqi He
Modified: 2019-06-04 10:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
Node log (11.88 KB, text/plain)
2018-11-06 05:52 UTC, Wenqi He
no flags Details
ControllerYaml (6.71 KB, text/plain)
2018-11-06 05:53 UTC, Wenqi He
no flags Details
Describe controller pod (6.24 KB, text/plain)
2018-11-06 05:54 UTC, Wenqi He
no flags Details
Driver Yaml (6.24 KB, text/plain)
2018-11-06 05:55 UTC, Wenqi He
no flags Details
Describe driver pod (5.84 KB, text/plain)
2018-11-06 05:55 UTC, Wenqi He
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:58 UTC

Description Wenqi He 2018-11-06 05:52:16 UTC
Created attachment 1502279 [details]
Node log

Description of problem:
Failed to deploy hostpath driver with CSI operator on https://github.com/openshift/csi-operator

Version-Release number of selected component (if applicable):
openshift v4.0.0-0.40.0
kubernetes v1.11.0+d4cacc0


How reproducible:
Always

Steps to Reproduce:
1. Follow the steps to deploy csi operator and hostpath driver
2. oc apply -f deploy/prerequisites (as admin and below)
3. oc apply -f deploy/operator.yaml
4. oc apply -f deploy/samples/hostpath.yaml

Actual results:
All the pods created in default project are CrashLoopBackOff

# oc get pods
NAME                                   READY     STATUS             RESTARTS   AGE
hostpath-controller-7d8b7468c8-l9q4j   3/4       CrashLoopBackOff   10         13m
hostpath-node-2nnjg                    2/3       CrashLoopBackOff   10         13m
hostpath-node-89kr5                    2/3       CrashLoopBackOff   9          13m
hostpath-node-rb25c                    2/3       CrashLoopBackOff   9          13m
hostpath-node-vzqbk                    2/3       CrashLoopBackOff   9          13m

Will attach all pods ouputs yaml and described info

Expected results:
All pods are running and operator can deploy hostpath driver successfully


Node Log (of failed PODs):
Attached


Additional info:

Comment 1 Wenqi He 2018-11-06 05:53:35 UTC
Created attachment 1502280 [details]
ControllerYaml

Comment 2 Wenqi He 2018-11-06 05:54:35 UTC
Created attachment 1502281 [details]
Describe controller pod

Comment 3 Wenqi He 2018-11-06 05:55:09 UTC
Created attachment 1502282 [details]
Driver Yaml

Comment 4 Wenqi He 2018-11-06 05:55:43 UTC
Created attachment 1502283 [details]
Describe driver pod

Comment 6 Liang Xia 2018-11-06 08:18:11 UTC
Actually, the image names in internal/external registry are different, it is inconsistent at the moment. In long tern, it can confusing users.

Comment 12 Jan Safranek 2019-01-03 13:02:13 UTC
Indeed, liveness probe can't access driver socket if the driver runs as privileged container. Fix: https://github.com/openshift/csi-operator/pull/40

Comment 14 Wenqi He 2019-02-11 08:02:40 UTC
We are not going to support csi-operator in 4.0, I just try to deploy the hostpath driver from step by step, the pods are running well.

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-02-10-115019   True        False         6h        Cluster version is 4.0.0-0.nightly-2019-02-10-115019

$ uname
Linux
$ cat /etc/redhat-release 
Red Hat CoreOS release 4.0

$ oc get pods
NAME                                   READY     STATUS    RESTARTS   AGE
csi-operator-cf8dd4fb-zczn9            1/1       Running   0          8m48s
hostpath-controller-6bfddc9f97-j5cnc   4/4       Running   0          6m
hostpath-node-lct28                    3/3       Running   0          6m
hostpath-node-sh7fr                    3/3       Running   0          6m
hostpath-node-t828m                    3/3       Running   0          6m

Comment 17 errata-xmlrpc 2019-06-04 10:40:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.