Bug 1646861 - Update gluster volume options set on the volume
Summary: Update gluster volume options set on the volume
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.3.0
: 4.3.0
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: 1647032
TreeView+ depends on / blocked
 
Reported: 2018-11-06 07:50 UTC by SATHEESARAN
Modified: 2019-05-08 12:39 UTC (History)
7 users (show)

Fixed In Version: ovirt-engine-4.3.0_alpha
Doc Type: Bug Fix
Doc Text:
This release ensures Red Hat Virtualization Manager sets the recommended options during the creation of a volume from Red Hat Virtualization Manager to distinguish creating volumes from the Cockpit User Interface.
Clone Of:
: 1647032 (view as bug list)
Environment:
Last Closed: 2019-05-08 12:38:47 UTC
oVirt Team: Gluster
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:1085 0 None None None 2019-05-08 12:39:02 UTC
oVirt gerrit 95282 0 master MERGED engine: Adding missing volume options 2018-11-08 04:59:35 UTC
oVirt gerrit 95318 0 ovirt-engine-4.2 MERGED engine: Adding missing volume options 2018-11-08 07:03:49 UTC
oVirt gerrit 95320 0 ovirt-engine-4.2.7.z MERGED engine: Adding missing volume options 2018-11-08 11:48:21 UTC

Description SATHEESARAN 2018-11-06 07:50:21 UTC
Description of problem:
-----------------------
When gluster volumes are created from RHV Manager UI and optimized, then there are few volume options set on the volume requires update.

Following options should be enabled:
    performance.strict-o-direct=enable
    network.remote-dio=disable

Following options to be removed:
    server.allow-insecure=on


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHV 4.2.7

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Create a gluster volume
2. Optimize the gluster volume for virt store

Actual results:
---------------
Required volume options are not set on the volume

Expected results:
------------------
All the required volume options needs to be set on the volume

Comment 2 Sahina Bose 2018-11-06 10:42:32 UTC
Also added cluster.granular-entry-heal: enable

Comment 6 SATHEESARAN 2019-03-12 17:27:05 UTC
Tested with RHV 4.3.2

All the requested volume options are set on the volume

Comment 8 errata-xmlrpc 2019-05-08 12:38:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1085


Note You need to log in before you can comment on or make changes to this bug.