Bug 1646888 - Godot fails to initiate rendering since Mesa 18.2.3 update
Summary: Godot fails to initiate rendering since Mesa 18.2.3 update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: godot
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Rémi Verschelde
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-06 08:48 UTC by Clemens Albrecht
Modified: 2018-11-07 09:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-07 09:34:41 UTC


Attachments (Terms of Use)

Description Clemens Albrecht 2018-11-06 08:48:08 UTC
Description of problem:
Program start with

ERROR: _display_error_with_code: CanvasShaderGLES3: Fragment Program Compilation Failed:
0:89(2): error: invalid input layout qualifier used

and

ERROR: get_current_version: CanvasShaderGLES3: Fragment Program Compilation Failed:
0:89(2): error: invalid input layout qualifier used

and displays blank screen.


Version-Release number of selected component (if applicable):
3.0.6-1

How reproducible:


Steps to Reproduce:
1. Use Intel integrated graphics (tested: HD5500)
2. Upgrade mesa from 18.2.2 to 18.2.3 or 18.2.4
3.

Actual results:


Expected results:


Additional info:

Comment 1 Rémi Verschelde 2018-11-06 08:53:30 UTC
As far as I can tell it's due to the bogus Mesa 18.2.3 update on F29: https://bodhi.fedoraproject.org/updates/FEDORA-2018-bcdb732491

Many QA tests mentioned it was broken but Bodhi auto-pushed it to stable nevertheless. If the 18.2.4 candidate does not fix it either, the update should be reverted to 18.2.2 until a proper fix is found.

According to https://bodhi.fedoraproject.org/updates/mesa-18.2.3-1.fc29#comment-857231 the update is broken due to a GCC update.

Comment 2 Rémi Verschelde 2018-11-06 13:17:24 UTC
I asked an affected Godot user to downgrade to 18.2.2, and he confirms that it fixed the bug.

Both 18.2.3 and 18.2.4 (currently in testing) are broken.

Comment 3 Rémi Verschelde 2018-11-06 13:20:22 UTC
> 18.2.4 (currently in testing)

Well it was just pushed to stable. It's still broken though.

Comment 4 Rémi Verschelde 2018-11-06 16:35:40 UTC
Should likely be fixed by https://bodhi.fedoraproject.org/updates/FEDORA-2018-b73380a8e4 (18.2.4-2) which was just pushed to stable.

Could you confirm Clemens?

Comment 5 Clemens Albrecht 2018-11-06 19:24:22 UTC
Ok nice. I am currently not on my Laptop.
I will confirm it later this evening or tomorrow.

Comment 6 Clemens Albrecht 2018-11-07 08:51:13 UTC
I just installed the 18.2.4-2 update.
It seems to have finally fixed the issue.
Godot is working properly again.

Comment 7 Rémi Verschelde 2018-11-07 09:34:41 UTC
Thanks, closing as fixed by https://bodhi.fedoraproject.org/updates/FEDORA-2018-b73380a8e4 then.


Note You need to log in before you can comment on or make changes to this bug.