Bug 1646923 - Errata needed for OVS bonds, updelay/downdelay settings ignored
Summary: Errata needed for OVS bonds, updelay/downdelay settings ignored
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openvswitch2.10
Version: 7.7-Alt
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Timothy Redaelli
QA Contact: Wang HeKai
URL:
Whiteboard:
Depends On:
Blocks: 1646707
TreeView+ depends on / blocked
 
Reported: 2018-11-06 10:19 UTC by Timothy Redaelli
Modified: 2019-04-28 09:04 UTC (History)
13 users (show)

Fixed In Version: openvswitch2.10-2.10.0-27.el7fdn
Doc Type: If docs needed, set a value
Doc Text:
Cause: Several versions of OVS including 2.10 ignore updelay and downdelay settings on bonds. Consequence: The updelay and downdelay parameters will be ignored, and the default value will be used. Workaround (if any): Although there is no workaround, the default updelay and downdelay values should work for most environments, and there have so far been no reports of undesirable behavior. Result: The updelay and downdelay settings will have no effect until OVS is upgraded to a new version.
Clone Of: 1646707
Environment:
Last Closed: 2019-01-07 08:51:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0029 None None None 2019-01-07 08:51:23 UTC

Description Timothy Redaelli 2018-11-06 10:19:21 UTC
+++ This bug was initially created as a clone of Bug #1646707 +++

Description of problem:
Open vSwitch has a bug in the LACP bond implementation, such that the updelay and downdelay parameters are ignored. This bug was recently fixed, but is not yet available in any version of OVS in OSP.

Version-Release number of selected component (if applicable):
OVS 2.10

How reproducible:
100%

Steps to Reproduce:
1. Configure an OVS bond with balance-tcp mode (LACP) and updelay or downdelay configured in the options
2.
3.

Actual results:
The updelay and downdelay settings are ignored.

Expected results:
The updelay and downdelay settings should be respected.

Additional info:
The default settings seem to be working, since we haven't received any customer reports of any issues. However, this bug may come up, so we should have an errata for this issue. We are unlikely to backport these changes in OVS to previous versions of OSP, so this issue will remain until we use a newer version of OVS that includes this patch:

https://patchwork.ozlabs.org/patch/982091/

Comment 9 errata-xmlrpc 2019-01-07 08:51:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0029


Note You need to log in before you can comment on or make changes to this bug.