Bug 164697 - Windows XP wont boot after instaling FC4 w/ hw RAID 0 (Missing NTLDR)
Windows XP wont boot after instaling FC4 w/ hw RAID 0 (Missing NTLDR)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
Mike McLean
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-30 11:31 EDT by Rodrigo M C Silva
Modified: 2008-05-06 11:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 11:30:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodrigo M C Silva 2005-07-30 11:31:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I had windows XP sp2 working properly on my RAID0 'virtual' disk C:\, and when I installed FC4 on the unpartitioned space in HD3, winxp dont boot and I get the message:

Missing NTLDR
Press Ctrl+Alt+Del to reboot the system.


Here are some details about the partitions:
--------------------------------------------------------------------------------
[root@Rodrigo ~]# fdisk -l

Disk /dev/hda: 81.9 GB, 81964302336 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1        8286    66557263+   7  HPFS/NTFS
/dev/hda2   *        8287        8299      104422+  83  Linux
/dev/hda3            8300        9964    13374112+  8e  Linux LVM

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       19458   156296353+   7  HPFS/NTFS

Disk /dev/sdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/sdb doesn't contain a valid partition table
--------------------------------------------------------------------------------

And here the 'grub.conf' file...

--------------------------------------------------------------------------------
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,1)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/hda
default=1
timeout=5
splashimage=(hd0,1)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.11-1.1369_FC4)
	root (hd0,1)
	kernel /vmlinuz-2.6.11-1.1369_FC4 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
	initrd /initrd-2.6.11-1.1369_FC4.img
title Other
	rootnoverify (hd0,0)
	chainloader +1


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Build RAID0 array
2. Install WinXP NTFS in RAID0 'virtual' disk.
3. Install SP2
4. Format HD3
5. Install FC4 in HD3
  

Actual Results:  FC4 boots normally.
Selecting 'Other' in Grub gets message 'Missing NTLDR. Press Ctrl+Alt+Del to reboot system.'

Expected Results:  FC4 and WinXP booting normally.

Additional info:

Main Processor: AMD Athlon XP 1900+
Motherboard: ASUS A7N8X Deluxe PCB 2.0 nForce2 Latest BIOS
Memory: Kingston 2x256Mb Dual Channel
Videocard: Radeon 9600 Pro 256Mb AGP 8x
HD1: Seagate SATA ST380013AS 80Gb
HD2: Seagate SATA ST380817AS 80Gb
HD3: Maxtor 80Gb -> 70Gb NTFS (Free space) -> 10Gb Unpartitioned (FC4)
Raid chipset: Silicon Image Sil3112A
RAID0 Drive: HD1+HD2 -> 100% NTFS -> Boots WinXP
Comment 1 Rodrigo M C Silva 2005-07-31 17:45:58 EDT
Looks like anaconda put grub in HD3, I´ve tried to uninstall FC4 and forcing 
anaconda to put grub in HD1. It worked fine again, but winxp dont boot at all. 
It looks to me that I cant modify the grub.conf file to boot from sda1 (HD1)...
Comment 2 peihung.lee 2005-08-12 20:35:41 EDT
I can't install Windows XP on my ASUS L7300 & IBM Thinkpad T30 which are both
installed with FC4 on them. The Windows XP installation process will hang, which
shows nothing after the "detecting hardware..." step.

However, it's gonna work if I remove the original partition table created by FC4.
I wonder if my problem is somewhat related to this bug.
Comment 3 Christian Iseli 2007-01-22 06:16:46 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 4 Evan 2007-02-20 18:33:40 EST
I apologize for creating a separate bug, when this one is clearly the same issue.

I can _confirm_ that this bug applies to the latest FC6 release. I have not
tried this on the FC7 test, but I could do so if needed.



*Differences*
I do not have RAID. The fact that Rodrigo had raid is irrelevant. It was likely
that he had multiple hard disks. 

I specifically told anaconda not to install grub on the Windows XP partition, in
fear that it might cause this exact problem. I also changed the BIOS boot
priorities. 



*Similarities*
I have an almost identical setup. 

Maybe one of the hard disks being Serial ATA might have something to do with it,
since that is one of the things that we have in common.

I have a 64 bit (AMD Opteron) processor. He also has a 64 bit processor and also
chose the i686 (aka x86-64).

I have actually 3 Hard disks.
1 SATA - NTFS - Windows XP pro
2 ATA - FAT - none
3 ATA - EXT3 - Fedora Core 6

*Details*

I apologize that I cannot give more specific information than that at the
moment. My Windows XP cannot read the ext3 partition and none of my Live CDs
seem to work on this computer either. This issue is due to an unrelated graphics
card problem (the refresh rate is set way to high and the monitors cannot
display it). 

I can give you in fairly good detail what I did using anaconda. If you do not
mind, I will paste in what I used in the other bug report.

After installing Fedora Core 6 the first time on my computer, I tried to boot
normally. However the screen only displayed about 6 lines of something like 66
66 66. I'm not entirely certain, I do remember that there were a lot of 6s and a
few random symbols strewn about in between. I also remember that this was not a
separate screen. The series of 6s were right below the IRQ information in what
is my standard boot up (bios) screen.

I thought that the boot loader (GRUB) must not have installed properly, so I put
the install DVD back in to do a repair. I used advanced configuration and told
it to install in the first sector of the hard disk. I was careful not to use my
primary windows disk, because of fear that just this problem might happen.

My CMOS allows me to choose which hard disk to boot into, so I booted into the
hard disk with GRUB on it, and it comes back with the error "NTLDR is missing,
press ctrl + alt + del to restart". This error seems far less severe than the
previous random bunch of numbers, so I reinstall it, thinking that I just
configured it wrong. 

This time I tell it to install in the MBR of the second (non-windows - FAT)
disk. This configuration also gives me the error "NTLDR is missing...

I have read that this can be fixed by replacing Ntldr and Ntdetect.com. This may
only be for those trying to fix a Windows installation. Even if I wanted to try,
this is extremely difficult in my case, because of the aforementioned ext3 issue.
Comment 5 petrosyan 2008-02-27 00:06:58 EST
Fedora Core 6 is not maintained anymore. Can anybody reproduce this bug in Fedora 8?
Comment 6 Bug Zapper 2008-04-03 21:59:55 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 7 Bug Zapper 2008-05-06 11:30:42 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.