Bug 16470 - Programs built with gcc no longer run on a remote server
Programs built with gcc no longer run on a remote server
Status: CLOSED DEFERRED
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-17 16:39 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-17 16:39:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-08-17 16:39:23 EDT
I have moved to the very latest Red Hat gcc-2.96-52 along with, cpp and
libstdc++

I have a simple web page renderer written in C. Building this single file
program with this latest gcc results in it NOT executing on the remote
server !
Well to be more accurate I don't know if it is not running or just not
outputing anything ! It is neither writing to stdout nor to a file, that's
for
sure !

It runs locally, not in a server domain, I mean just running it from the
command line and watching the HTML spewing out into the console. 

I was running gcc-2.95-9.2mdk, which worked fine. But I have also seen
these
symptoms with a Mandrake version, I can't however remember which one.

What could have been done to gcc that allows programs to run locally but
not
when called via a script on a remote Apache server

Any help would be appreciated since it is a real pain having to switch
compilers !

Thanks, 
Owen
Comment 1 Jakub Jelinek 2000-08-25 14:47:29 EDT
Without a testcase I cannot do really anything about it.
Please reopen if you have a self-contained testcase which triggers
some miscompilation in gcc.
Try compiling with -O0 to see if it cures it (if it does, then please
track it down to a particular .c file which causes it not to work even
when all other files are compiled with -On n>=1), if not, try compiling
it with some older gcc (like egcs from RH6.2) and similarly mix objects
up to see which one if compiled by egcs and all others are compiled by gcc
makes the bug go away.

Note You need to log in before you can comment on or make changes to this bug.