Bug 1647033 - libmspack-0.8-0.1.alpha corrupts extracted cab files
Summary: libmspack-0.8-0.1.alpha corrupts extracted cab files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libmspack
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-06 14:53 UTC by Kamil Páral
Modified: 2018-11-13 02:26 UTC (History)
2 users (show)

Fixed In Version: libmspack-0.9.1-0.1.alpha.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-13 02:26:53 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Kamil Páral 2018-11-06 14:53:03 UTC
Description of problem:
After update to libmspack-0.8-0.1.alpha, extracted cab files are corrupted. Everything works fine with libmspack-0.7-0.1.alpha.

Reproducer:
$ wget 'https://download.microsoft.com/download/8/4/A/84A35BF1-DAFE-4AE8-82AF-AD2AE20B6B14/directx_Jun2010_redist.exe'

With libmspack-0.7-0.1.alpha:
$ cabextract -F 'Apr2005_d3dx9_25_x86.cab' directx_Jun2010_redist.exe 
Extracting cabinet: directx_Jun2010_redist.exe
  extracting Apr2005_d3dx9_25_x86.cab

All done, no errors.
$ md5sum Apr2005_d3dx9_25_x86.cab 
b7457f5d50176d38d36a2e2dc0429fd2  Apr2005_d3dx9_25_x86.cab

With libmspack-0.8-0.1.alpha:
$ cabextract -F 'Apr2005_d3dx9_25_x86.cab' directx_Jun2010_redist.exe 
Extracting cabinet: directx_Jun2010_redist.exe
  extracting Apr2005_d3dx9_25_x86.cab

All done, no errors.
$ md5sum Apr2005_d3dx9_25_x86.cab 
f252f57b017125a5a1fb0e137b06051a  Apr2005_d3dx9_25_x86.cab

As you can see, the hashsums differ.

Please note that this only seems to happen if you use "cabextract -F". Without "-F", the files don't get corrupted.

Version-Release number of selected component (if applicable):
libmspack-0.7-0.1.alpha.fc28.x86_64

How reproducible:
always

Comment 1 Rex Dieter 2018-11-06 21:05:54 UTC
Thanks!

Looks like there's an new upstream release with fix for this.  I'll get that imported asap.

Comment 2 Fedora Update System 2018-11-06 22:27:29 UTC
cabextract-1.9-1.fc28 libmspack-0.9.1-0.1.alpha.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cb337fb199

Comment 3 Fedora Update System 2018-11-07 04:24:32 UTC
cabextract-1.9-1.fc28, libmspack-0.9.1-0.1.alpha.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cb337fb199

Comment 4 Kamil Páral 2018-11-07 13:00:30 UTC
Thanks for quick response, the fix seems to work

Comment 5 Fedora Update System 2018-11-13 02:26:53 UTC
cabextract-1.9-1.fc28, libmspack-0.9.1-0.1.alpha.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.