Bug 164707 - Cursor displays incorrectly on non-X consoles
Summary: Cursor displays incorrectly on non-X consoles
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 4
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-30 17:45 UTC by Martin Burchell
Modified: 2015-01-04 22:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-12 06:44:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from dmesg (15.03 KB, text/plain)
2005-07-30 17:53 UTC, Martin Burchell
no flags Details

Description Martin Burchell 2005-07-30 17:45:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
When typing into a non-X console, a flashing blob up to 4x8 characters in size appears beneath the cursor.


Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1398_FC4

How reproducible:
Always

Steps to Reproduce:
1.Go to non-X console eg. Control-alt F2
2.Type in some characters
3.
  

Actual Results:  The flashing blob appears below the cursor

Expected Results:  No flashing blob, cursor drawn correctly

Additional info:

I'm guessing this is specific to the Intel 845 driver

Switching to a different console will get rid of the blob but type in a few more characters and it will reappear.

Wasn't a problem in FC3

Comment 1 Martin Burchell 2005-07-30 17:53:54 UTC
Created attachment 117312 [details]
Output from dmesg

Comment 2 Martin Burchell 2005-07-30 17:55:46 UTC
I meant 8x4 characters not 4x8


Comment 3 Olivier Baudron 2005-08-12 10:51:59 UTC
Fixed in xorg-6.8.2-45.

*** This bug has been marked as a duplicate of 161242 ***

Comment 4 Martin Burchell 2005-08-12 20:36:51 UTC
I'm sorry, but this is not the same bug as 161242.  Changing libvgahw.a and
rebooting makes no difference.  I still get the same problem


Comment 5 Olivier Baudron 2005-08-12 20:44:21 UTC
Can you try xorg-6.8.2-45 ?

Comment 6 Martin Burchell 2005-08-12 21:55:41 UTC
(In reply to comment #5)
> Can you try xorg-6.8.2-45 ?

Yes I've now updated the following packages and rebooted, but still no luck 8^(

Aug 12 22:45:41 Updated: glibc-common.i386 2.3.90-8
Aug 12 22:46:06 Updated: glibc.i686 2.3.90-8
Aug 12 22:46:10 Updated: xorg-x11-libs.i386 6.8.2-45
Aug 12 22:46:15 Updated: glibc-headers.i386 2.3.90-8
Aug 12 22:46:17 Updated: xorg-x11-xfs.i386 6.8.2-45
Aug 12 22:46:18 Updated: xorg-x11-deprecated-libs.i386 6.8.2-45
Aug 12 22:46:40 Updated: xorg-x11-devel.i386 6.8.2-45
Aug 12 22:46:40 Updated: xorg-x11-deprecated-libs-devel.i386 6.8.2-45
Aug 12 22:46:52 Updated: xorg-x11.i386 6.8.2-45
Aug 12 22:46:54 Updated: glibc-devel.i386 2.3.90-8


Comment 7 Dave Jones 2005-09-30 07:21:27 UTC
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.


Comment 8 Martin Burchell 2005-10-06 22:48:05 UTC
(In reply to comment #7)
> Mass update to all FC4 bugs:
> 
> An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
> kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
> previous kernel, it's possible your bug has been fixed already.
> 
> Please retest with this update, and update this bug if necessary.

I no longer get the flashing blob having updated to the new kernel.  The console
text is back to pre-FC4 size ie big.  Not sure if this is related, but I don't
really mind.


Comment 9 Dave Jones 2005-11-10 21:55:49 UTC
Mass update to all FC4 bugs:

An update has been released (2.6.14-1.1637_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.



Comment 10 Martin Burchell 2005-11-11 21:43:44 UTC
(In reply to comment #9)
> Mass update to all FC4 bugs:
> 
> An update has been released (2.6.14-1.1637_FC4) which rebases to a new upstream
> kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
> previous kernel, it's possible your bug has been fixed already.
> 
> Please retest with this update, and update this bug if necessary.

Console text is back to small size and there is no flashing blob so I think this
is fixed.


Note You need to log in before you can comment on or make changes to this bug.