Bug 164710 - change tpb's osd color to gray
change tpb's osd color to gray
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tpb (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-30 15:02 EDT by Seth Vidal
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-26 10:44:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seth Vidal 2005-07-30 15:02:33 EDT
Description of problem:
current osd color is green. It is that ugly terminal green that makes me think
of avada kedavra and pain.

Version-Release number of selected component (if applicable):
all of them afaict.

How reproducible:
just use it. view the dark-lord inspired pain of the default osd color.

  
Actual results:
green at its most painful

Desired results:
a soothing, relaxing gray, something without all the pain and suffering.


It's a small config file change and it makes a big difference.
Comment 1 Ville Skyttä 2005-07-31 04:42:47 EDT
I tend to agree, but OTOH I think the chances of finding a default that would 
appease everyone are very thin. 
 
The visibility of gray OSD when displayed over app windows using the grayish 
default FC color scheme is not good.  Green has been the default for ages in 
this package, and nobody has complained so far. 
 
I'm open to suggestions, but IMO gray _works_ considerably worse than green, 
aesthetic considerations aside, so I'm inclined not to switch to it.  Other 
suggestions / differing opinions? 
Comment 2 Seth Vidal 2005-08-01 00:15:30 EDT
I use a light grey color scheme and it looks great to me.  It's so obviously in
an overlay above the current window I doubt it would cause much confusion.

Comment 3 Patrick Jordan 2005-09-25 21:24:13 EDT
I don't think 'Gray' looks bad or confusing, it's just a bit bland.  Red looks 
cool, but might be mistaken for a warning.  

On another note, the comment above osdcolor says the default is Blue.  It must
be the default if osdcolor is not defined, but fc's tpbrc defaults to Green.
Comment 4 Ville Skyttä 2005-09-26 10:44:30 EDT
Yep, IIRC I didn't stick with the default of blue because it didn't work too   
well with some RH/FC distros' default wallpaper that contained a lot of blue   
in it. 
   
Anyway, as said in comment 1, I don't think there's much chance of finding a   
better default that would appease everyone, so I'm not going to change it at   
least for now.  Things are already configurable in /etc/tpbrc and 
$HOME/.tpbrc.  If you feel strongly about this, please discuss on 
fedora-extras-list. 

Note You need to log in before you can comment on or make changes to this bug.