Bug 164717 - renders fonts differently than other GTK2 apps
Summary: renders fonts differently than other GTK2 apps
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard: FF3RawhideClose
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-30 23:50 UTC by Bill Nottingham
Modified: 2018-04-11 19:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 16:46:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xmag of two titlebars (12.52 KB, image/png)
2005-07-30 23:50 UTC, Bill Nottingham
no flags Details

Description Bill Nottingham 2005-07-30 23:50:19 UTC
$ rpm -q firefox gtk2 pango cairo
firefox-1.1-0.2.5.deerpark.alpha2
gtk2-2.7.4-1
pango-1.9.1-1
cairo-0.6.0-1.1

(cairo-0.6.0-1.1 is actually 2005-07-29 CVS, to avoid the crasher.)

Firefox renders fonts differently than other GTK2 apps, most noticeably in the
titlebar.

The attached xmag screenshot shows it best - firefox is on the top, liferea on
the bottom.

Looks like firefox isn't using subpixel AA, while other apps are.

Comment 1 Bill Nottingham 2005-07-30 23:50:19 UTC
Created attachment 117317 [details]
xmag of two titlebars

Comment 2 Matěj Cepl 2007-12-20 16:46:59 UTC
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays


Note You need to log in before you can comment on or make changes to this bug.