Bug 1647176
| Summary: | Backport Intermitent error on OpenShift HAProxy Router reload fixes to 3.10 | ||
|---|---|---|---|
| Product: | OpenShift Container Platform | Reporter: | Ram Ranganathan <ramr> |
| Component: | Networking | Assignee: | Ram Ranganathan <ramr> |
| Networking sub component: | router | QA Contact: | Hongan Li <hongli> |
| Status: | CLOSED ERRATA | Docs Contact: | |
| Severity: | high | ||
| Priority: | high | CC: | acavalla, ajuricic, akaiser, aos-bugs, bbennett, bleanhar, bperkins, dmace, guilherme.camposo, hongli, mmagnani, openshift-bugs-escalate, ramr, rhowe, rpenta, zzhao |
| Version: | 3.10.0 | ||
| Target Milestone: | --- | ||
| Target Release: | 3.10.z | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: |
Cause: When wildcard routes are enabled and namespace ownership checks are disabled, non-wildcard routes get removed and immediately re-added on the resync interval boundaries and this causes a brief route outage and results in intermittent errors on a route.
Consequence: Intermittent errors on non-wildcard routes. See cause above.
Fix: To not remove and re-add the routes on resync interval in the specific case when wildcard routes enabled and namespace ownership checks are disabled.
Result: non-wildcard routes continue to serve without any intermittent errors after the fix.
|
Story Points: | --- |
| Clone Of: | 1624078 | Environment: | |
| Last Closed: | 2018-12-13 17:09:08 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | 1624078 | ||
| Bug Blocks: | |||
|
Comment 1
Ram Ranganathan
2018-11-06 19:43:23 UTC
vefied with atomic-openshift-3.10.83-1.git.0.a4cc75b.el7 and issue has been fixed.
steps as below:
1. enable wildcard and disable namespace ownership check.
$ oc set env dc/router ROUTER_ALLOW_WILDCARD_ROUTES=true ROUTER_DISABLE_NAMESPACE_OWNERSHIP_CHECK=true
2. create your project, pod, svc and non-wildcard route.
3. set loglevel=4 for router
$ oc patch dc -n default router -p '[{"op": "add", "path": "/spec/template/spec/containers/0/args", "value":["--loglevel=4"]}]' --type=json
Check the logs and no deleting/re-adding normal routes while router resyncing (every 10min).
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2018:3750 |