This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 164720 - blue fringing on the drag window down and drag window right mouse cursors
blue fringing on the drag window down and drag window right mouse cursors
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-30 20:22 EDT by Patrick
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-09 07:51:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Patrick 2005-07-30 20:22:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
The mouse cursor has an unexpected blue fringe when hovering over a window edge to drag the window down or to the right. The icons for drag left and drag up appear fine.

I am using the nv open source driver on an nVidia GeForge FX 5200.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-37

How reproducible:
Sometimes

Steps to Reproduce:
While hovering and also while dragging a window down or to the right the mouse cursor is fringed with blue. This usually always happens but I've noticed some anomalies which are hard to place. Dragging a terminal window from the top of the screen down to the bottom does not cause the fringing. And sometimes I *think* dragging up the screen makes the effect go away. Usually, however the mouse cursor for dragging the bottom of a window or the right of a window causes the blue fringing on the top-left side of the mouse cursor.

Additional info:
Comment 1 Patrick 2005-07-30 20:29:35 EDT
I've looked at the effect again and I think it is actually reproducable. The
mouse cursor appears to blue fringe when a portion of the cursor is on top of
the window border decoration while you drag. For some reason it is easier while
dragging a terminal window to have the mouse cursor move entirely below the
terminal window being dragged while if you drag down a firefox window the mouse
cursor almost always stays overlapping the window border decoration and is
therefore more noticable.

I'm using the clearlooks window-border theme as part of gtk2-engines-2.6.3-2.
Comment 2 Mike A. Harris 2005-08-30 09:54:22 EDT
If this issue turns out to still be reproduceable in the latest
updates for this Fedora Core release, please file a bug report
in the X.Org bugzilla located at http://bugs.freedesktop.org in
the "xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", and awaiting upstream
bug report URL for tracking.

Thanks in advance.
Comment 3 Mike A. Harris 2006-01-17 21:24:15 EST
This bug has been idle without feedback for about 5 months now.  I am unable
to reproduce the problem on the video hardware I have available, however I
do not have the specifically indicated nvidia hardware, so am unable to
test on that specific device.  Our hardware lab does not have that hardware
either.

I would recommend experimenting with the "swcursor" option and
see if that makes any difference.  Alternatively try the "noaccel" option.
Also try both options together.  If none of these cause the problem you are
seeing to go away, try using the "vesa" driver to see if the issue occurs
there as well.  Another possibility (although not recommended, as we do
not support it) is to try the proprietary nvidia driver.  If the problem
occurs (or doesn't occur) on particular drivers, or if the problem goes
away with the suggested configuration options, that would help to narrow
down where the problem exists.

If the problem turns out to be in the "nv" driver however, you'll still
need to file a bug report in X.Org bugzilla, as a bug in the nv driver
would require Nvidia to investigate and resolve the problem as they do
not provide hardware documentation to the community, and the driver source
code is intentionally obfuscated.

I'll leave this bug open for another week or so to await a response, however
if no response is forthcoming, we'll assume the problem is no longer present,
or that there is no longer interest in tracking the issue.

Thanks in advance.
Comment 4 Mike A. Harris 2006-02-09 07:51:32 EST
Closing bug due to lack of information, and lack of feedback/response.
If the issue is still present/relevent, please respond to the above
engineering queries and reopen and we will re-review the issue.

Setting status to "CANTFIX" (lack of response)


Note You need to log in before you can comment on or make changes to this bug.