Bug 1647274 - "flag provided but not defined: -namespaces" error for prometheus-operator pod with OCP images
Summary: "flag provided but not defined: -namespaces" error for prometheus-operator po...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Frederic Branczyk
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-07 02:17 UTC by Junqi Zhao
Modified: 2019-10-28 08:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
configmap and prometheus-operator pod logs (8.18 KB, text/plain)
2018-11-07 02:17 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:58 UTC

Description Junqi Zhao 2018-11-07 02:17:06 UTC
Created attachment 1502798 [details]
configmap and prometheus-operator pod logs

Description of problem:
Deploy cluster monitoring with OCP images, "flag provided but not defined: -namespaces" error for prometheus-operator
# oc -n openshift-monitoring  get pod
NAME                                           READY     STATUS             RESTARTS   AGE
cluster-monitoring-operator-65c4b68b44-2wc5s   1/1       Running            0          17m
prometheus-operator-5cd9c78bfb-bdbv2           0/1       CrashLoopBackOff   8          17m
**********************************************************************************************
# oc -n openshift-monitoring logs prometheus-operator-5cd9c78bfb-bdbv2
flag provided but not defined: -namespaces
Usage of /usr/bin/operator:
........................
----------snipped----------

Version-Release number of selected component (if applicable):
ose-cluster-monitoring-operator-v4.0.0-0.48.0.0
ose-prometheus-operator-v4.0.0-0.48.0.0

How reproducible:
Always

Steps to Reproduce:
1. Deploy cluster monitoring with OCP images
2.
3.

Actual results:
"flag provided but not defined: -namespaces" error for prometheus-operator

Expected results:
prometheus-operator should be healthy

Additional info:

Comment 1 Junqi Zhao 2018-11-07 02:17:56 UTC
Blocks installation with OCP images

Comment 2 Frederic Branczyk 2018-11-09 10:59:23 UTC
This is related to us not having bumped the prometheus-operator repository to the appropriate version, this is in progress. https://github.com/openshift/prometheus-operator/pull/10

Comment 3 lserven 2018-11-19 11:59:39 UTC
https://github.com/openshift/prometheus-operator/pull/10 is now merged and new ose-prometheus-operator-v4.0.0-0 should be built. Can you please retest the cluster monitoring operator on OSE to verify that this problem is resolved?

Comment 4 Nicholas Nachefski 2018-11-27 15:24:25 UTC
Still seeing this in 4.0.0-0.75.0.

# oc logs prometheus-operator-57ccd85b94-dhxdn |head -n5
flag provided but not defined: -namespaces
Usage of /usr/bin/operator:
  -alertmanager-default-base-image string
    	Alertmanager default base image (default "quay.io/prometheus/alertmanager")
  -alsologtostderr

Comment 5 Nicholas Nachefski 2018-11-27 15:38:18 UTC
# skopeo inspect --tls-verify=false docker://satellite.home.nicknach.net:8888/openshift/ose-prometheus-operator:v4.0 |grep release
        "release": "0.74.0.0",

Comment 6 Junqi Zhao 2018-11-28 01:32:27 UTC
(In reply to lserven from comment #3)
> https://github.com/openshift/prometheus-operator/pull/10 is now merged and
> new ose-prometheus-operator-v4.0.0-0 should be built. Can you please retest
> the cluster monitoring operator on OSE to verify that this problem is
> resolved?

Issue is not fixed, see Comment 4 and Comment 5.
Do we need to test the OCP images by using the Next-Gen installer?

Comment 7 Nicholas Nachefski 2018-12-01 17:46:33 UTC
Still not fixed in 0.79.0.0

Comment 9 Junqi Zhao 2018-12-04 01:01:35 UTC
@Lucas

See Comment 5, Comment 7, Comment 8.

Issue is not fixed.
Do we need to test the OCP images by using the Next-Gen installer?

Comment 15 Nicholas Nachefski 2018-12-11 14:35:11 UTC
confirmed fixed in 4.0.0-0.93.0 (docker container runtime).  

I'll test crio here in a bit.

Thanks!

-Nick

Comment 16 Junqi Zhao 2018-12-19 08:30:08 UTC
Issue is fixed, see Comment 15

Comment 20 errata-xmlrpc 2019-06-04 10:40:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.