Bug 1647283 - [admin] Optional field for storageclass does not bind default storageclass to pvc on creation page
Summary: [admin] Optional field for storageclass does not bind default storageclass to...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Zac Herman
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-07 03:26 UTC by XiaochuanWang
Modified: 2019-06-04 10:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Change of api naming convention Consequence: Default storage class would not bind Fix: Adjusted api naming so default class will be triggered Result: Fixed
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:59 UTC

Description XiaochuanWang 2018-11-07 03:26:34 UTC
Description of problem:
On PVC creation page, leave the optional field "Storage Class" unselected and create, then the pvc does not bind the default storageclass.

Version-Release number of selected component (if applicable):
v4.0.0-0.48.0
registry.reg-aws.openshift.com:443/openshift/ose-console                   v4.0                f543eb8039d7

How reproducible:
Always

Steps to Reproduce:
1. Make sure there is a default storageclass for the cluster. (storageclass.beta.kubernetes.io/is-default-class: 'true')
2. Go to PVC creation (From Form) page
3. Since there is a message "Optional storage class for the new claim.". Just leave the optional field "Storage Class" unselected, fill the other necessary fields. Then hit Create.
4. Check the created pvc.

Actual results:
4. Created PVC does not bind the default storageclass.

Expected results:
4. Created PVC should be Bound using the default storageclass.

Additional info:

Comment 1 Zac Herman 2018-11-07 21:41:38 UTC
https://github.com/openshift/console/pull/770 should resolve this

Comment 2 XiaochuanWang 2018-11-13 03:31:34 UTC
Verified on latest OCP v4.0.0-0.52.0

Storage class is not optional for the form, PVC could be saved and bound succeedfully with default SC. YAML is correct ->  spec.storageClassName: gp2

Comment 5 errata-xmlrpc 2019-06-04 10:40:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.