Bug 164731 - php interprets .php.gz files
php interprets .php.gz files
Status: CLOSED DUPLICATE of bug 163971
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-31 02:04 EDT by Bug Master
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-01 04:55:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bug Master 2005-07-31 02:04:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686; en) Opera 8.01

Description of problem:
.php.gz files are interpret as .php files instead of .gz files

Version-Release number of selected component (if applicable):
httpd-2.0.54-10, php-5.0.4-10.3

How reproducible:
Always

Steps to Reproduce:
1. gzip a php file
2. place in web tree
3. attempt to retrieve.
  

Actual Results:  This shows up in the error log:

[client <ipaddress>] PHP Warning:  Unexpected character in input:  '\x06' 
(ASCII=6) state=1 in /home/html/projects/test.php.gz on line 219, referer: http:/
/eder.us/projects/test.html

An empty file is returned to the browser

Expected Results:  test.php.gz should be downloaded.  PHP should not be a part of the request.

Additional info:
Comment 1 Joe Orton 2005-08-01 04:55:49 EDT
Please see bug 163971 comment 3 for a workaround.

*** This bug has been marked as a duplicate of 163971 ***

Note You need to log in before you can comment on or make changes to this bug.