Bug 1647323 - certain combination of --help and --output=csv causes Error: undefined method `[]' for nil:NilClass
Summary: certain combination of --help and --output=csv causes Error: undefined method...
Keywords:
Status: CLOSED DUPLICATE of bug 1649231
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-07 08:24 UTC by Peter Ondrejka
Modified: 2018-11-13 08:39 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-13 08:39:14 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1649231 None CLOSED hammer --help does not work with --output json, csv and yaml 2019-06-12 13:40:04 UTC

Internal Links: 1649231

Description Peter Ondrejka 2018-11-07 08:24:39 UTC
Description of problem:

runninng:

hammer -v -u admin -p changeme --output=csv organization list --help --per-page="10000"

ends with Error: undefined method `[]' for nil:NilClass

Seemingly this is influenced by the position of --output=csv argument, moving it to the end mitigates the issue.

Version-Release number of selected component (if applicable):
Satellite 6.5 snap 2

Comment 2 Tomas Strachota 2018-11-13 08:39:14 UTC
Good catch Nikhil, they're dupes. I didn't spot it early enough and happened to clone the other issue - I'm sorry for that. I'm going to close this one for a bit more complete description of the other.

Peter, just for you to know: Hammer ignores any parameter that comes after --help or -h. Not best approach but it's a feature of the framework that we use (Clamp). Hence moving --output=csv to the end "mitigates" the issue.

*** This bug has been marked as a duplicate of bug 1649231 ***


Note You need to log in before you can comment on or make changes to this bug.