Bug 164735 - Bad: Exception in anaconda creating logical volumes
Summary: Bad: Exception in anaconda creating logical volumes
Status: CLOSED DUPLICATE of bug 160255
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-31 08:30 UTC by chris siegler
Modified: 2007-11-30 22:11 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2005-07-31 11:36:24 UTC


Attachments (Terms of Use)

Description chris siegler 2005-07-31 08:30:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
I get this when starting the installation of packages on my Toshiba A75-S211. 

An unhandled exception has occured. This is most likely a bug. Please copy
the full text of this exception and file a detailed bug report against anaconda at http://bugzilla.redhat.com/bugzilla/

Traceback (most recent call last)
File "/usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
  self.currentWindow.renderCallback()
File "/usr/lib/anaconda/iw/progress_gui.py", line 244, in renderCallback
  self.intf.icw.nextClicked()
File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
  self.dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
  self.moveStep()
File "/usr/lib/anaconda/packages.py", line 582, in turnOnFilesystems
  thefsset.createLogicalVolumes(instPath)
File "/usr/lib/anaconda/fsset.py", line 1472, in createLogicalVolumes
  entry.device.setupDevice(chroot)
File "/usr/lib/anaconda/fsset.py", line 2066, in setupDevice
  raise SystemError, "pvcreate failed for %s" % (volume,)
SystemError" pvcreate failed for <fsset.PartitionDevice instance at 0xb7b2e4ec>



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot from FC4 DVD
2. choose either graphical or text installation. Both fail.
3. start package installation
  

Actual Results:  popup "Exception Occured" dialog box

Additional info:

I tried manually changing the partitions to 'ext3' rather than LVM, but then I get a dialog box saying it can't format hda at the same point.

AFAIK, there's nothing wrong with the drive or laptop. Latest Ubuntu installed just fine and I had no problem later restoring Windows XP Home. I'm using the laptop right now. I don't see any options in the BIOS that seem relevent.

Comment 1 Gerwin Krist 2005-07-31 11:36:24 UTC

*** This bug has been marked as a duplicate of 160255 ***


Note You need to log in before you can comment on or make changes to this bug.