Bug 164747 - n-c-b don't recognize blank or rewriteable media.
n-c-b don't recognize blank or rewriteable media.
Status: CLOSED DUPLICATE of bug 163799
Product: Fedora
Classification: Fedora
Component: nautilus-cd-burner (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Depends On:
  Show dependency treegraph
Reported: 2005-07-31 11:57 EDT by Gustavo Maciel Dias Vieira
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-12-16 04:51:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gustavo Maciel Dias Vieira 2005-07-31 11:57:23 EDT
Description of problem:

I can't record a CD using n-c-b. No matter what is in the drive (and I have
tested a *lot* of combinations), Nautilus asks to insert a blank CD in the drive.

In n-c-b, I've created an ISO image and manually recorded it using cdrecord with
no problems. So my drive, media and kernel seem to be working. Also, lshal
indicates correctly the status of the media currently in the drive. For example,
here is a sample for a blank CD-RW:

  volume.disc.is_rewritable = true  (bool)
  volume.disc.is_appendable = false  (bool)
  volume.disc.is_blank = true  (bool)

Version-Release number of selected component (if applicable):

Fedora Core 4, updated.

How reproducible:


Steps to Reproduce:
1. Try to record a CD using n-c-b
Comment 1 Gustavo Maciel Dias Vieira 2005-07-31 12:01:42 EDT
Two things I forgot to mention:

My CD burner is a HP CD Writer Plus 9100b.

Writing CDs in n-c-b worked flawlessly in FC3 for the same setup.
Comment 2 David Bentley 2005-08-10 09:06:47 EDT
This is the same problem as described in 163799 but I can confirm that it is
present both in FC4 and Development which are different versions 2.10 and 2.11
so is there some other underlying common problem.

My CD Burners are a Memorex Twelve MAXX 1032 in my development system and
Yamaha CRW8424E in my FC4 system.

LSHAL output can be supplied if required.

I actually have another system that was network installed from the Development
tree which does work OK the only difference in the "LSHAL" output that I can
see is on the systems that dont work the volume.disc.type = 'unknown' where on
the working system (with a PIONEER DVD-RW DVR-106D) returns a 
volume.disc.type = 'cd_r' 

So is this a "HAL" problem with some types of cd-recorder.

NB both CD-R and CD-RW return "unknown"
Comment 3 David Nielsen 2005-10-31 02:46:54 EST
Same thing happens on Rawhide using my LITE-ON LTR-40125S

packages in question:

Also n-c-b doesn't obey the /apps/nautilus-cd-burner/default_speed key seeing as
my burner is pretty arse it tends to do bad burns at speeds above 12x, however
n-c-b defaults to as fast as possible, in this case 40x (and the selector is
greyed out) - highly annoying.
Comment 4 Gustavo Maciel Dias Vieira 2005-12-04 06:36:22 EST
An update to this problem. I've changed my recorder and now there are some
combinations that work (I'm not sure if its related to the new drive, though).
My new drive is a LG GSA-4163B and the software are the same versions. Now I can
record to:
  * a blank CD-RW
  * a blank DVD-RW (Restricted Overwrite mode, didn't test others)
  * an *unmounted* non-blank CD-RW (it asks to erase it)
  * an *unmounted* non-blank DVD-RW (it asks to erase it)

I still can't record to a mounted CD/DVD-RW. This used to work in FC3 where
n-c-b whould automaticaly blank the CD-RW. A workaround is to disable
auto-mounting of removable media.

I may not seem like much, but n-c-b is (was) one of the first things I teached a
Linux novice to use, because its so simple and easy. They used to marvel at how
Linux was simpler than Windows. Now I have to teach them apologetically create
an ISO and burn at the command line...
Comment 5 Alexander Larsson 2005-12-16 04:51:56 EST

*** This bug has been marked as a duplicate of 163799 ***

Note You need to log in before you can comment on or make changes to this bug.