Bug 164748 - Wrong whois output on .de Domains
Wrong whois output on .de Domains
Status: CLOSED DUPLICATE of bug 132362
Product: Fedora
Classification: Fedora
Component: jwhois (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Depends On:
  Show dependency treegraph
Reported: 2005-07-31 12:17 EDT by Dominik Bay
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-07-31 21:18:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dominik Bay 2005-07-31 12:17:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050715 Firefox/1.0.6 SUSE/1.0.6-4.1

Description of problem:
If i type in `jwhois etherkiller.de` i get the wrong whois output:

[Querying http://www.denic.de/en/whois/data.jsp]

   [1]Search  [2]Search
   [3]Sitemap [4]Sitemap

The correct output starts with:

[Querying whois.denic.de]
% Copyright (c)2004 by DENIC
% Version: 1.03.3

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Type in jwhois denic.de

Actual Results:  [Querying http://www.denic.de/en/whois/data.jsp]

   [1]Search  [2]Search
   [3]Sitemap [4]Sitemap

Expected Results:  [Querying whois.denic.de]
% Copyright (c)2004 by DENIC
% Version: 1.03.3

Additional info:

--- /etc/jwhois.conf    2005-04-30 19:47:56.000000000 +0200
+++ /etc/jwhois.conf.new        2005-07-31 20:15:03.000000000 +0200
@@ -180,7 +180,10 @@
        "\\.cx$" = "whois.nic.cx";
        "\\.cy$" = "whois.ripe.net";
        "\\.cz$" = "whois.nic.cz";
-       "\\.de$" = "www.denic.de";
+        "\\.de$" {
+                 whois-server = "whois.denic.de";
+                 query-format = "-C UTF-8 -T dn,ace $*";
+        }
        "\\.dk$" = "whois.dk-hostmaster.dk";
        "\\.do$" = "whois.nic.do";
        "\\.dz$" = "whois.ripe.net";
Comment 1 Miloslav Trmač 2005-07-31 21:18:15 EDT
Thanks for your report.

The proposed change assumes that the program is running with LC_CTYPE
set to a locate using UTF-8; this is in general not the case.
The current configuration allows graceful degradation (e.g. ü -> ue)
if some characters are not supported.

I have written patch to add character set conversion to jwhois, but the maintainer
so far doesn't seem to have time to review it.

*** This bug has been marked as a duplicate of 132362 ***

Note You need to log in before you can comment on or make changes to this bug.