This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 164753 - ping6 util has -M option, but ignores it. (IPv6)
ping6 util has -M option, but ignores it. (IPv6)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: iputils (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
:
Depends On:
Blocks: IPv6Blocker
  Show dependency treegraph
 
Reported: 2005-07-31 15:26 EDT by Gregory Maxwell
Modified: 2014-11-09 17:30 EST (History)
2 users (show)

See Also:
Fixed In Version: iputils-20071127
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-19 09:48:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gregory Maxwell 2005-07-31 15:26:55 EDT
Description of problem:

The -M option on IPv4 ping controls setting of the don't fragment bit.
The option 'do' is described as:  do (prohibit fragmentation, even local one)

IPv6 doesn't provide network based fragmentation, so the -M pmtu setting should
only apply locally, the man page for ping implies it will, but it does not.

The ability to control fragmentation with ping is very useful for network
debugging esp in an enviroment with tunnels as is common with IPv6.

Version-Release number of selected component (if applicable):
iputils-20020927-22


How reproducible:
Completely


Steps to Reproduce:
1. ping6 -s 8000 -M do dualstack_host
2. ping -s 8000 -M do dualstack_hist
3.
  
Actual results:
[root@hypatia ~]#  ping6 -s 8000 -M do goethe.freenode.net
PING goethe.freenode.net(sterling.freenode.net) 8000 data bytes
8008 bytes from sterling.freenode.net: icmp_seq=1 ttl=58 time=292 ms
8008 bytes from sterling.freenode.net: icmp_seq=2 ttl=58 time=302 ms
8008 bytes from sterling.freenode.net: icmp_seq=3 ttl=58 time=293 ms
8008 bytes from sterling.freenode.net: icmp_seq=4 ttl=58 time=290 ms

--- goethe.freenode.net ping statistics ---
5 packets transmitted, 4 received, 20% packet loss, time 4006ms
rtt min/avg/max/mdev = 290.902/294.720/302.116/4.370 ms, pipe 2

Expected results:
Some sort of ICMP error about fragmentation needed.

Additional info:
Comment 1 Sitsofe Wheeler 2005-08-01 14:12:43 EDT
An aside, but wouldn't tracepath6 be a better tool for debugging things like
tunnel sizes?
Comment 2 Gregory Maxwell 2005-08-01 14:20:04 EDT
(In reply to comment #1)
> An aside, but wouldn't tracepath6 be a better tool for debugging things like
> tunnel sizes?

Yep. Doesn't mean ping shouldn't work as expected. ;)
Comment 4 Radek Vokal 2005-11-08 04:42:15 EST
(In reply to comment #0)
> Description of problem:
> 
> IPv6 doesn't provide network based fragmentation, so the -M pmtu setting should
> only apply locally, the man page for ping implies it will, but it does not.
> 
> The ability to control fragmentation with ping is very useful for network
> debugging esp in an enviroment with tunnels as is common with IPv6.
> 

Does this mean that it should work or should not, cos IPv6 doesn't have a
capability for it? 
Comment 6 Charles R. Anderson 2007-10-13 12:25:01 EDT
Of course IPv6 has a capability for fragmentation--just end-host based, not
router based fragmentation.  This bug still exists in iputils-20070202-5.fc8.
Please update the version to "devel".  Thanks.
Comment 7 Gregory Maxwell 2007-10-13 16:40:16 EDT
Why is this bug still sitting at need-info? :( I don't see what more information
is needed.
Comment 8 Charles R. Anderson 2007-10-13 16:52:50 EDT
Gregory Maxwell, since you are the submitter of this bug, could you please
change  the Version to devel and the Status to ASSIGNED or similar?  Only the
submitter, assignee, and a few others can make such changes.  I tried clicking
"I am providing the requested information for this bug." but it doesn't work for me.
Comment 9 Jiri Skala 2008-06-19 09:48:17 EDT
(In reply to comment #0)
> Version-Release number of selected component (if applicable):
> iputils-20020927-22

The iputils-20020927-22 is from FC4. There is a test result of release
iputils-20071127 of FC9 below. I tested also older releases (FC8) and works also
fine.


[jskala@...]$ ping6 -c 4 -s 8000 -M do fec0::f101:215:c5ff:fef3:e54f
PING fec0::f101:215:c5ff:fef3:e54f(fec0::f101:215:c5ff:fef3:e54f) 8000 data bytes
From fec0::f101:21c:25ff:fe76:6547 icmp_seq=1 Packet too big: mtu=1500
From fec0::f101:21c:25ff:fe76:6547 icmp_seq=1 Packet too big: mtu=1500
From fec0::f101:21c:25ff:fe76:6547 icmp_seq=1 Packet too big: mtu=1500
From fec0::f101:21c:25ff:fe76:6547 icmp_seq=1 Packet too big: mtu=1500

--- fec0::f101:215:c5ff:fef3:e54f ping statistics ---
0 packets transmitted, 0 received, +4 errors

Note You need to log in before you can comment on or make changes to this bug.