Bug 1647611 - EPEL7 - python-django won't install on RHEL 7.6
Summary: EPEL7 - python-django won't install on RHEL 7.6
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-django16
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: EPEL7-Deps
TreeView+ depends on / blocked
 
Reported: 2018-11-07 22:11 UTC by Troy Dawson
Modified: 2018-12-30 20:20 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-12-19 00:39:23 UTC


Attachments (Terms of Use)

Description Troy Dawson 2018-11-07 22:11:05 UTC
Current python-django for EPEL7 (python-django-1.6.11.6-1.el7) requires
  python-django-bash-completion = 1.6.11.6-1.el7
EPEL7 contains
  python-django-bash-completion = 1.6.11.7-1.el7

Please fix this package so that it can be installed in RHEL 7.6.
If you have not responded in a week, we will have a proven packager fix it.
If you know you will not be able to get to it and would like it fixed sooner, please let us know in this bug.
If you feel this package should no longer be in EPEL7, please let us know in this bug.

Comment 1 Troy Dawson 2018-11-07 22:13:10 UTC
There is a new package python-django16 that contains the packages
  python2-django
  python-django-bash-completion

As you can see, the subpackage python-django-bash-completion
 conflicts between the two packages.

I am not the package maintainer, but if it were me, I'd either remove the python-django package, or update the new python-django16 so that the bash-completion is python2-django-bash-completion

Comment 2 Miro Hrončok 2018-11-07 23:01:49 UTC
Why has python-django16 been added to EPEL7 when python-django is 1.6 @EPEL7 as well?

Comment 3 Stephen Gallagher 2018-11-08 00:53:39 UTC
(In reply to Miro Hrončok from comment #2)
> Why has python-django16 been added to EPEL7 when python-django is 1.6 @EPEL7
> as well?

The python-django maintainer (Matthias Runge) asked me to split off 1.6 into its own package because he had planned to upgrade EPEL 7 to be a more modern Django installation. I still need this ancient version because it's used by Review Board. Apparently Matthias never followed through on the upgrade. Someone should take over the ownership of python-django and upgrade it or retire it.

My python-django16 package does have a bug in it though (it should be building python-django16-bash-completion). I just pushed a fix and it's building now.

Comment 4 Fedora Update System 2018-11-08 00:56:01 UTC
python-django16-1.6.11.7-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-bac5bfddaf

Comment 5 Matthias Runge 2018-11-08 07:24:11 UTC
(In reply to Stephen Gallagher from comment #3)
> (In reply to Miro Hrončok from comment #2)
> > Why has python-django16 been added to EPEL7 when python-django is 1.6 @EPEL7
> > as well?
> 
> The python-django maintainer (Matthias Runge) asked me to split off 1.6 into
> its own package because he had planned to upgrade EPEL 7 to be a more modern
> Django installation. I still need this ancient version because it's used by
> Review Board. Apparently Matthias never followed through on the upgrade.
> Someone should take over the ownership of python-django and upgrade it or
> retire it.

Ugh, I'm sorry about this. 

For me, it turned out, that EPEL has some severe issues itself, and I currently don't have an interest in maintaining anything in EPEL. iirc, we should have an antique version of Django in EPEL. Upgrading to a more modern (and still supported) version would be the upgrade to 1.11.

I've filed https://pagure.io/epel/issue/48

Comment 6 Miro Hrončok 2018-11-08 11:12:59 UTC
(In reply to Stephen Gallagher from comment #3)
> (In reply to Miro Hrončok from comment #2)
> > Why has python-django16 been added to EPEL7 when python-django is 1.6 @EPEL7
> > as well?
> 
> The python-django maintainer (Matthias Runge) asked me to split off 1.6 into
> its own package because he had planned to upgrade EPEL 7 to be a more modern
> Django installation. I still need this ancient version because it's used by
> Review Board. Apparently Matthias never followed through on the upgrade.
> Someone should take over the ownership of python-django and upgrade it or
> retire it.

Thanks for clarification.

> My python-django16 package does have a bug in it though (it should be
> building python-django16-bash-completion). I just pushed a fix and it's
> building now.

And thanks for the fix!

Comment 7 Fedora Update System 2018-11-09 07:58:48 UTC
python-django16-1.6.11.7-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-bac5bfddaf

Comment 8 Fedora Update System 2018-11-21 18:35:17 UTC
python-django-1.11.13-4.el7, python-django16-1.6.11.7-5.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-2206653eb9

Comment 9 Troy Dawson 2018-12-18 15:21:33 UTC
The fixed package has reached it's testing time.
Does anyone mind if I push it to stable?

Comment 10 Matthias Runge 2018-12-18 16:38:09 UTC
Thanks for the heads-up. I just pushed both python-django packages to batched. Since this is an upgrade, we wanted some feedback, which did not really happen.

Comment 11 Fedora Update System 2018-12-19 00:39:23 UTC
python-django-1.11.13-4.el7, python-django16-1.6.11.7-5.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 lonordtea 2018-12-30 19:55:13 UTC
graphite-web-0.9.16-2.el7 is currently broken as it requires `python-django >= 1.3` and the new package has meant it’s leapt from 1.6 -> 1.11 which is incompatible. 

The spec file requires needs toT be updated to require "python2-django16 >= 1.3"

Comment 13 Stephen Gallagher 2018-12-30 20:20:51 UTC
(In reply to lonordtea from comment #12)
> graphite-web-0.9.16-2.el7 is currently broken as it requires `python-django
> >= 1.3` and the new package has meant it’s leapt from 1.6 -> 1.11 which is
> incompatible. 
> 
> The spec file requires needs toT be updated to require "python2-django16 >=
> 1.3"

That bug needs to be filed against graphite-web.


Note You need to log in before you can comment on or make changes to this bug.