Bug 1647653 - [4.0]Did not remove message about jenkins autoprovision in samplepipeline.yaml template
Summary: [4.0]Did not remove message about jenkins autoprovision in samplepipeline.ya...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Templates
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.1.0
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
wewang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-08 03:22 UTC by wewang
Modified: 2019-06-04 10:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:59 UTC

Description wewang 2018-11-08 03:22:47 UTC
Description of problem:
Did not remove message about jenkins autoprovision in  samplepipeline.yaml template, Should remove it, because dropped jenkins autoprovision in 4.0 version

Version-Release number of selected component (if applicable):
openshift v4.0.0-0.49.0

How reproducible:
always 

Steps to Reproduce:
1.Check the jenkins pipeline template, which include " A Jenkins server will be automatically instantiated in this project"

2.Create pipeline build, also include"A Jenkins server will be automatically instantiated in this project"
 
$oc new-app -f https://raw.githubusercontent.com/openshift/origin/master/examples/jenkins/pipeline/samplepipeline.yaml

$ oc new-app -f https://raw.githubusercontent.com/openshift/origin/master/examples/jenkins/pipeline/samplepipeline.yaml

     Pipeline Build Example
     ---------
     This example showcases the new Jenkins Pipeline integration in OpenShift,
     which performs continuous integration and deployment right on the platform.
     The template contains a Jenkinsfile - a definition of a multi-stage CI/CD process - that
     leverages the underlying OpenShift platform for dynamic and scalable
     builds. OpenShift integrates the status of your pipeline builds into the web
     console allowing you to see your entire application lifecycle in a single view.
     A Jenkins server will be automatically instantiated in this project to manage
     the Pipeline BuildConfig created by this template.  You will be able to log in to
     it using your OpenShift user credentials.

3.

Actual results:
It has message about jenkins autoprovision info in jenkins pipeline template

Expected results:
Should remove jenkins autoprovision info in jenkins pipeline template 

Additional info:
bluegreen-pipeline.yaml has the same issue

Comment 1 Gabe Montero 2018-11-08 15:02:43 UTC
PR https://github.com/openshift/origin/pull/21451

Comment 2 Gabe Montero 2018-11-09 20:34:03 UTC
OK PR https://github.com/openshift/origin/pull/21451 has merged

moving onto QA

Comment 3 wewang 2018-11-12 03:15:57 UTC
Yes, it's already fixed in ose,thanks

Comment 6 errata-xmlrpc 2019-06-04 10:40:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.