Bug 1647801 - can't enable shared-storage
Summary: can't enable shared-storage
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sanju
QA Contact:
URL:
Whiteboard:
Depends On: 1647029
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-08 11:57 UTC by Sanju
Modified: 2020-01-09 17:27 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1647029
Environment:
Last Closed: 2018-11-29 15:21:29 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21570 0 None None None 2018-11-08 11:57:35 UTC
Gluster.org Gerrit 21598 0 None Merged glusterd: allow shared-storage to use bricks under glusterd working directory 2018-11-08 17:08:12 UTC

Description Sanju 2018-11-08 11:57:35 UTC
+++ This bug was initially created as a clone of Bug #1647029 +++

Description of problem:
"gluster v set all cluster.enable-shared-storage enable" command is not creating a shared-storage-volume.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. enable shared-storage
2. check for glusterd-shared-storage on "gluster volume info" output
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2018-11-08 17:24:32 IST ---

REVIEW: https://review.gluster.org/21570 (glusterd: allow shared-storage to use bricks under glusterd working directory) posted (#3) for review on master by Atin Mukherjee

Comment 1 Worker Ant 2018-11-08 12:00:34 UTC
REVIEW: https://review.gluster.org/21598 (glusterd: allow shared-storage to use bricks under glusterd working directory) posted (#1) for review on release-5 by Sanju Rakonde

Comment 2 Worker Ant 2018-11-08 17:08:11 UTC
REVIEW: https://review.gluster.org/21598 (glusterd: allow shared-storage to use bricks under glusterd working directory) posted (#2) for review on release-5 by Shyamsundar Ranganathan

Comment 3 Shyamsundar 2018-11-29 15:21:29 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.1, please open a new bug report.

glusterfs-5.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-November/000116.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.