Bug 164781 - Gnome panel will not dock to the edge of the visible workspace after logon.
Gnome panel will not dock to the edge of the visible workspace after logon.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-01 08:15 EDT by Alex Roberts
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-02 10:10:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A screenshot of what happens right after logging in. (1.30 MB, image/png)
2005-08-02 09:31 EDT, Alex Roberts
no flags Details
A screenshot of the panel before logging out. (1.31 MB, image/png)
2005-08-02 09:35 EDT, Alex Roberts
no flags Details

  None (edit)
Description Alex Roberts 2005-08-01 08:15:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
The gnome-panel, when set to not expand, will not attach itself to the side of the window after logon unless it is done manually. Previously, in FC2 and FC3 this behavior worked. 

Version-Release number of selected component (if applicable):
gnome-panel-2.10.1-10.2

How reproducible:
Always

Steps to Reproduce:
1. Set gnome panel to not expand and drag it to the bottom right corner.
2. Log off and log on.
3. 
  

Actual Results:  The bottom panel was not in the bottom right corner as it had been before I logged off.

Expected Results:  The bottom panel should have been in the bottom right corner.

Additional info:

I run two panels, top and bottom, that are set to not expand nor autohide giving me smaller panels and some extra room to dock applications.
Comment 1 Mark McLoughlin 2005-08-02 04:28:29 EDT
What applets does this panel contain? Maybe just attach before-logout and
after-login screenshots?
Comment 2 Alex Roberts 2005-08-02 09:31:32 EDT
Created attachment 117360 [details]
A screenshot of what happens right after logging in.
Comment 3 Alex Roberts 2005-08-02 09:34:30 EDT
The panel is running the workspace switcher, the notification applet, the
gnome-pilot applet, the mail notification applet, the 'logout' button and a
custom launcher to launch mutt in an xterm. It used to have an applet for
Tomboy, but I removed that to see if it was the culprit as mono would take a bit
to initialize.
Comment 4 Alex Roberts 2005-08-02 09:35:22 EDT
Created attachment 117361 [details]
A screenshot of the panel before logging out.
Comment 5 Mark McLoughlin 2005-08-02 10:10:29 EDT
Ah, I know what's going on here.

When the pager applet starts up first it momentarily takes up a lot more space
(width-wise) than it should and so expands the panel, causing the panel's
position to change. When the pager applet goes back to its normal size, the
panel stays in that new position.

I don't think anything changed in this area since GNOME 2.4, so I'm surprised
that you say it worked with FC3.

Tracking this problem upstream:

  http://bugzilla.gnome.org/show_bug.cgi?id=312362

Thanks

Note You need to log in before you can comment on or make changes to this bug.