Bug 164782 - RFE: add support for diskless clients based on iSCSI
RFE: add support for diskless clients based on iSCSI
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-netboot (Show other bugs)
5.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jaroslav Reznik
BaseOS QE
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-01 08:30 EDT by bastiaan
Modified: 2010-04-06 09:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-06 09:08:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bastiaan 2005-08-01 08:30:42 EDT
Currently system-config-netboot only supports diskless clients via NFS. It would
be nice to be able to configure booting of iSCSI based diskless clients as well.
Especially since system-config-netboot does complain that the boot files in
/tftpboot/linux-install/pxelinug.cfg/ you've created manually for iSCSCI-boot
refer to a profile which 'is not PXE Operating System' and you cannot add that
profile to pxeos.xml.
FYI. I've been successfull in setting op diskless iSCSI booting using iscsi-init
(http://sourceforge.net/projects/iscsi-init/). Create an initrd with:
mkinitrd \
        --preload=<network-module> --with=iscsi_sfnet --with=iscsi_init \
        initrd-iscsi-<network-module>.img <kernel-version>
 
And configure initiator name, target name, etc. either in the dhcp server or in
the boot file. 
I'll try to reuse the initrd creation used for NFS diskless clients so you don't
have to create a separate initrd for every network card.
Would RedHat consider booting with iscsi-init or would setting up iscsid from
the initrd be the preferred approach?
Comment 1 Jason Vas Dias 2005-08-01 09:22:40 EDT
I am currently looking into enhancing system-config-netboot to support iSCSI,
as well as other non-PXE boot protocols such as eLiLo and yaboot .
I've CC-ed the iSCSI maintainer on this request, to look into integrating 
any existing iSCSI boot client configuration tools with system-config-netboot.
You may have a problem "reus[ing] the existing initrd used for NFS diskless
clients", as the "init" script, "disklessrc", currently uses NFS only .

Comment 2 bastiaan 2005-08-01 10:12:37 EDT
Great to hear you are already looking into this.
My intention was to hack disklessrc a bit to enable iSCSI support, not to use it
verbatim. What I haven't figured out yet is how to create the initrd: with NFS
one can mount the client fs on the netboot server, but with iSCSI this is not so
straightforward. Any ideas on this?


Comment 3 bastiaan 2005-09-22 12:17:48 EDT
Hi Jason, I've been working on iscsi-boot for RHEL3 the past month(s) and now
have a working initrd and creation tool. Basically it is an adaption of
updateDiskless and disklessrc: I removed NFS and read-only root setup and added
iscsi init by iscsid, support for ethernet bonding, RAID1 and iSCSI target
configuration through DHCPs Root-Path parameter. Our primary usage is for
diskless servers, rather than clients, hence the RAID1 and bonding features. 
Since the netboot server typically cannot access the iSCSI disk of the client,
unlike with NFS, currently the updateDiskless tool has to be run on the client
rather than on the netboot server. So I don't see yet how this would integrate
into system-config-netboot. Maybe you have some ideas for this?

Comment 4 David Barksdale 2006-01-03 17:04:25 EST
Is there going to be bonding support added to system-config-netboot any time
soon? When can we expect this?
Thank you.
Comment 6 Alexander Todorov 2009-08-24 08:52:36 EDT
I think this is still relevant. Moving to RHEL5 so it can be on the radar.
Comment 7 RHEL Product and Program Management 2009-11-06 13:52:03 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 Jaroslav Reznik 2010-04-06 09:08:31 EDT
This is quite invasive change for RHEL 5 release and as system-config-netboot is now in maintenance mode only and there's no further development, I'm closing this RFE as WONTFIX now.

Note You need to log in before you can comment on or make changes to this bug.