Bug 164804 - /tmp/ssl_enable.ldif tries to modify non-existing cn=RSA,cn=encryption,cn=config
/tmp/ssl_enable.ldif tries to modify non-existing cn=RSA,cn=encryption,cn=config
Status: CLOSED UPSTREAM
Product: 389
Classification: Community
Component: wiki (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Chandrasekar Kannan
http://directory.fedora.redhat.com/wi...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-01 12:00 EDT by Darren Fulton
Modified: 2015-01-04 18:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-06 14:10:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darren Fulton 2005-08-01 12:00:20 EDT
Description of problem:
Documentation for enabling SSL for Fedora DS at
http://directory.fedora.redhat.com/wiki/Howto:SSL includes instructions for
creating an LDIF file at /tmp/ssl_enable.ldif.  That file contains a section
that reads:

dn: cn=RSA,cn=encryption,cn=config
changetype: modify
add: nsSSLPersonalitySSL
nsSSLPersonalitySSL: Server-Cert

That means to modify the dn: cn=RSA,cn=encryption,cn=config.  That section does
not exist in the directory and running the ldif generates errors.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Install DS
2.  Follow steps in Fedora-DS Samba How-to
3.  Follow steps in Fedora-DS SSL How-to
4.  It breaks when running the /tmp/ssl_enable.ldif due to "cn=RSA" not existing
Actual results:


Expected results:


Additional info:
Comment 1 Darren Fulton 2005-08-03 09:22:49 EDT
Adam S. posted this to the Fedora DS Users mailing list:

Thanks for pointing that out please create an ldif /tmp/addrsa.ldif and
have the following :

dn: cn=RSA,cn=encryption,cn=config
objectclass: top
objectclass: nsEncryptionModule
cn: RSA
nsSSLPersonalitySSL: Server-Cert
nsSSLToken: internal (software)

Use ldapadd to add the entry into the directory server.. Ill fix the
how-to now as well  :) 

adam
Comment 2 To Ngan 2005-08-05 12:48:26 EDT
Changed component to wiki
Comment 3 Nathan Kinder 2005-08-16 16:19:12 EDT
Adam has fixed this on the wiki site.
Comment 4 Anh Nguyen 2007-11-27 17:00:10 EST
I cleared the QA whiteboard for now.

Note You need to log in before you can comment on or make changes to this bug.