Bug 1648422 - python2-pysocks upgrade requires python-SocksiPy which conflicts with each other.
Summary: python2-pysocks upgrade requires python-SocksiPy which conflicts with each ot...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-pysocks
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-09 16:56 UTC by Edward
Modified: 2020-05-05 07:17 UTC (History)
11 users (show)

Fixed In Version: python-pysocks-1.6.8-7.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-05 07:17:33 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Edward 2018-11-09 16:56:48 UTC
Description of problem:
When I run 'yum upgrade' I see that python2-pysocks and python34-idna need to be updated and one of these thinks it requires python-SocksiPy.  Only proglem is python-SocksiPy is available via the atomic repo configured on this server and python-SocksiPy-1.00-4.el7.art.noarch conflicts with python2-pysocks-1.6.8-5.el7.noarch, which is the package that seems to require it.


Version-Release number of selected component (if applicable):
Current version of python2-pysocks installed is 1.6.7-1
Version to be upgraded to 1.6.8-5.

How reproducible:

Steps to Reproduce:
1.ssh to server
2.as root or sudo run 'yum upgrade -y'
3.

Actual results:
Transaction check error:
  file /usr/lib/python2.7/site-packages/socks.py conflicts between attempted installs of python2-pysocks-1.6.8-5.el7.noarch and python-SocksiPy-1.00-4.el7.art.noarch
  file /usr/lib/python2.7/site-packages/socks.pyc conflicts between attempted installs of python2-pysocks-1.6.8-5.el7.noarch and python-SocksiPy-1.00-4.el7.art.noarch
  file /usr/lib/python2.7/site-packages/socks.pyo conflicts between attempted installs of python2-pysocks-1.6.8-5.el7.noarch and python-SocksiPy-1.00-4.el7.art.noarch


Expected results:
updates to be installed without conflict or error.

Additional info:

Comment 1 Danny 2018-12-04 16:14:53 UTC
I am having this same issue.

Comment 2 Markus Schuster 2019-02-04 15:40:59 UTC
Same problem here.

The issue is pretty easily explained:

$ rpm --query --provides --package python2-pysocks-1.6.7-1.el7.noarch.rpm 
python-SocksiPy
python-pysocks = 1.6.7-1.el7
python2-SocksiPy
python2-pysocks = 1.6.7-1.el7

$ rpm --query --provides --package python2-pysocks-1.6.8-5.el7.noarch.rpm 
python-pysocks = 1.6.8-5.el7
python2-pysocks = 1.6.8-5.el7

The new version 1.6.8-5 in EPEL stopped providing the python-SocksiPy package.

Comment 3 Pavla Kratochvilova 2019-12-17 06:51:17 UTC
This is a packaging issue, so I am moving this to python-pysocks.

Comment 4 Fedora Update System 2020-04-20 01:44:26 UTC
FEDORA-EPEL-2020-3413d94460 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-3413d94460

Comment 5 Fedora Update System 2020-04-20 19:58:06 UTC
FEDORA-EPEL-2020-3413d94460 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-3413d94460

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2020-05-05 07:17:33 UTC
FEDORA-EPEL-2020-3413d94460 has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.