Bug 164862 - spinlock deadlock while running mirror I/O
Summary: spinlock deadlock while running mirror I/O
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jonathan Earl Brassow
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 145411
TreeView+ depends on / blocked
 
Reported: 2005-08-01 23:18 UTC by Corey Marthaler
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-02 21:43:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Corey Marthaler 2005-08-01 23:18:08 UTC
Description of problem:
While testing the fix for 164630, we were able to get around that race
condition, however that made it possible now to see a deadlock which could occur
when running I/O to a mirror. This was because two processes are both waiting on
the same spinlock.

Version-Release number of selected component (if applicable):
[root@link-02 ~]# lvcreate --version
  LVM version:     2.01.13 (2005-07-13)
  Library version: 1.01.03 (2005-06-13)
  Driver version:  4.4.0

*plus patches to fix 164630*

How reproducible:
everytime

Comment 1 Jonathan Earl Brassow 2005-08-02 21:43:39 UTC
This bug cropped up as an artifact of my fix for bug 164630, so it does _not_
currently exist in the kernel


Note You need to log in before you can comment on or make changes to this bug.