Bug 1648634 - SELinux is preventing sss_cache from 'write' accesses on the file config.ldb.
Summary: SELinux is preventing sss_cache from 'write' accesses on the file config.ldb.
Keywords:
Status: CLOSED DUPLICATE of bug 1640255
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:225824ead181aa5132282baf70f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-11 09:54 UTC by Mikhail
Modified: 2018-11-13 08:29 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-13 08:29:03 UTC
Type: ---


Attachments (Terms of Use)

Description Mikhail 2018-11-11 09:54:44 UTC
Description of problem:
SELinux is preventing sss_cache from 'write' accesses on the file config.ldb.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that sss_cache should be allowed write access on the config.ldb file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'sss_cache' --raw | audit2allow -M my-ssscache
# semodule -X 300 -i my-ssscache.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:groupadd_t:s0-s0:c0.c102
                              3
Target Context                system_u:object_r:sssd_var_lib_t:s0
Target Objects                config.ldb [ file ]
Source                        sss_cache
Source Path                   sss_cache
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.3-13.fc30.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.20.0-0.rc1.git2.1.fc30.x86_64 #1
                              SMP Wed Nov 7 22:40:39 UTC 2018 x86_64 x86_64
Alert Count                   6
First Seen                    2018-10-29 08:16:34 +05
Last Seen                     2018-11-11 14:52:49 +05
Local ID                      d4c77daf-e3cd-4a1a-859e-01afd3492844

Raw Audit Messages
type=AVC msg=audit(1541929969.844:395): avc:  denied  { write } for  pid=27550 comm="sss_cache" name="config.ldb" dev="nvme0n1p2" ino=2006634 scontext=unconfined_u:unconfined_r:groupadd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sssd_var_lib_t:s0 tclass=file permissive=0


Hash: sss_cache,groupadd_t,sssd_var_lib_t,file,write

Version-Release number of selected component:
selinux-policy-3.14.3-13.fc30.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.6
hashmarkername: setroubleshoot
kernel:         4.20.0-0.rc1.git2.1.fc30.x86_64
type:           libreport

Potential duplicate: bug 1640255

Comment 1 Lukas Slebodnik 2018-11-13 08:29:03 UTC

*** This bug has been marked as a duplicate of bug 1640255 ***


Note You need to log in before you can comment on or make changes to this bug.