Bug 1648671 - gnome-terminal not starting
Summary: gnome-terminal not starting
Keywords:
Status: CLOSED DUPLICATE of bug 1574222
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-terminal
Version: 29
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-11 15:19 UTC by Harald
Modified: 2018-11-11 16:51 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-11 16:51:30 UTC


Attachments (Terms of Use)

Description Harald 2018-11-11 15:19:32 UTC
Description of problem:
gnome-terminal doesn't start, when trying to start from Console an error message is reported on the console. When starting from Activities, it just doesn't show up without an error message.


Version-Release number of selected component (if applicable):


$ dnf info gnome-terminal
Failed to set locale, defaulting to C
Adobe Systems Incorporated                                                             1.7 kB/s | 1.9 kB     00:01    
Dropbox Repository                                                                     1.2 kB/s | 2.4 kB     00:02    
Fedora Modular 29 - x86_64                                                             427 kB/s | 1.5 MB     00:03    
negativo17 - Spotify                                                                   3.2 kB/s | 3.9 kB     00:01    
Fedora Modular 29 - x86_64 - Updates                                                   382 kB/s | 1.5 MB     00:04    
Fedora 29 - x86_64 - Updates                                                           3.1 MB/s |  11 MB     00:03    
Fedora 29 - x86_64                                                                     5.0 MB/s |  62 MB     00:12    
google-chrome                                                                          1.7 kB/s | 3.6 kB     00:02    
RPM Fusion for Fedora 29 - Free - Updates                                               18 kB/s |  70 kB     00:03    
RPM Fusion for Fedora 29 - Free                                                        327 kB/s | 759 kB     00:02    
RPM Fusion for Fedora 29 - Nonfree - Updates                                            10 kB/s |  11 kB     00:01    
RPM Fusion for Fedora 29 - Nonfree                                                      70 kB/s | 221 kB     00:03    
Installed Packages
Name         : gnome-terminal
Version      : 3.30.2
Release      : 1.fc29
Arch         : x86_64
Size         : 7.3 M
Source       : gnome-terminal-3.30.2-1.fc29.src.rpm
Repo         : @System
From repo    : updates
Summary      : Terminal emulator for GNOME
URL          : http://www.gnome.org/
License      : GPLv3+ and GFDL and LGPLv2+
Description  : gnome-terminal is a terminal emulator for GNOME. It features the ability to use
             : multiple terminals in a single window (tabs) and profiles support.



How reproducible:
Try starting gnome-terminal either from activities or from console

Steps to Reproduce:
1. Open console
2. start gnome-terminal
OR
1. Click on Activities (upper left corner)
2. Enter 'terminal'
3. Start by clicking on 'Terminal'

Actual results:
nothing appears on the Desktop, not even an error

When started from the console this is the output (gnome is started):
$ gnome-terminal 
# Locale not supported by C library.
#       Using the fallback 'C' locale.
# watch_fast: "/org/gnome/desktop/interface/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/settings-daemon/peripherals/mouse/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/sound/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/privacy/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/wm/preferences/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/settings-daemon/plugins/xsettings/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/a11y/" (establishing: 0, active: 0)
# watch_established: "/org/gnome/desktop/interface/" (establishing: 1)
# watch_established: "/org/gnome/settings-daemon/peripherals/mouse/" (establishing: 1)
# watch_established: "/org/gnome/desktop/sound/" (establishing: 1)
# watch_established: "/org/gnome/desktop/privacy/" (establishing: 1)
# watch_established: "/org/gnome/desktop/wm/preferences/" (establishing: 1)
# watch_established: "/org/gnome/settings-daemon/plugins/xsettings/" (establishing: 1)
# watch_established: "/org/gnome/desktop/a11y/" (establishing: 1)
# Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached


Expected results:
gnome-terminal to show up

Additional info:
happend since upgrade from F27 to F29.

I tried also to reinstall gnome-terminal:
dnf remove gnome-terminal
dnf install gnome-terminal

It didn't change anything.

Comment 1 Christian Persch 2018-11-11 15:47:14 UTC
$ gnome-terminal 
# Locale not supported by C library.

There you have the root problem already. You need to use a UTF-8 locale.

Comment 2 Harald 2018-11-11 16:51:30 UTC
I am using the UTF-8 locale, i have the language set to en_US.UTF-8 but the keyboard and the units set to de_DE.UTF-8. 

But it looks like I was able to identify the rootcause, and it is that the upgrade dropped the german language pack, causing the gnome-terminal to fail the start. The issue of dropped language pack has already an bug filed, as well as gnome-terminal not starting without LC_ALL being set.

With some research I found this issue: 
Bug 1185658 - gnome-terminal won't start without LC_ALL defined 

Now i checked my locale settings:
$ locale
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=de_DE.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=de_DE.UTF-8
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT=de_DE.UTF-8
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

=> So the missing setting of LC_ALL seems to cause the gnome-terminal not starting. Now I checked for the reason why this happened and I found this issue:
https://bugzilla.redhat.com/show_bug.cgi?id=1574222

A solution is described here, simply install the language pack again:
http://www.hack23.de/blog/2018/05/fedora-28-upgrade-problem-mit-locale-settings/

I run 
dnf install glibc-langpack-de
dnf reinstall gnome-terminal

and now the gnome-terminal is starting as it should (still not from the console, so this might be impossible anyway).

*** This bug has been marked as a duplicate of bug 1574222 ***


Note You need to log in before you can comment on or make changes to this bug.