Bug 1648687 - Incorrect usage of local->fd in afr_open_ftruncate_cbk
Summary: Incorrect usage of local->fd in afr_open_ftruncate_cbk
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
Assignee: Soumya Koduri
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1651322 1655527 1655578
TreeView+ depends on / blocked
 
Reported: 2018-11-11 17:30 UTC by Soumya Koduri
Modified: 2019-03-25 16:31 UTC (History)
2 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1651322 1655527 1655578 (view as bug list)
Environment:
Last Closed: 2018-11-20 08:53:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21617 0 None Open afr: open_ftruncate_cbk should read fd from local->cont.open struct 2018-11-15 05:08:04 UTC

Description Soumya Koduri 2018-11-11 17:30:46 UTC
Description of problem:

afr_open() stores fd reference in local->cont.open structure. But in the callback function "afr_open_ftruncate_cbk" ( when openflags contain 'O_TRUNC' set), we reference local->fd in AFR_STACK_UNWIND resulting in error or crash.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Soumya Koduri 2018-11-11 17:34:37 UTC
Patch posted for review - https://review.gluster.org/#/c/glusterfs/+/21617/

Comment 2 Worker Ant 2018-11-11 17:45:42 UTC
REVIEW: https://review.gluster.org/21617 (afr: open_ftruncate_cbk should read fd from local->cont.open struct) posted (#2) for review on master by soumya k

Comment 3 Worker Ant 2018-11-15 05:08:03 UTC
REVIEW: https://review.gluster.org/21617 (afr: open_ftruncate_cbk should read fd from local->cont.open struct) posted (#8) for review on master by Ravishankar N

Comment 4 Shyamsundar 2019-03-25 16:31:57 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.