Bug 164876 - Booting Hangs after Join Domain
Booting Hangs after Join Domain
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
http://forums.devshed.com/showthread....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-02 04:07 EDT by Jonny
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-14 09:31:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonny 2005-08-02 04:07:02 EDT
From Bugzilla Helper:
User-Agent: Opera/8.01 (Windows NT 5.1; U; en)

Description of problem:
I'm no expert so I doubt I've even got the correct package but I have found that 
after joining a domain e.g. localhost.localdomain to myserver.mydomain and 
rebooting the machine without the network cable plugged in the machine hangs at 
the point mentioned in the URL above.
I believe that it would be better to output an error message or continue booting 
and produce an error message later but I almost opted to install windows as I 
was having this problem - obviously I was the problem as I had 4 network sockets 
in teh back of the machine and had the cable plugged in to the wrong socket but 
an error message of: Could not join domain, network not found
would be much better than hanging and knowing nothing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Fedora
2.Change domain to join windows network
3.Unplug Network Cable (or plug in to wrong socket on server with 4 NICs)
  

Actual Results:  Machine hangs during boot when trying to boot network services

Expected Results:  I would appreciate an error message so I could rectify the problem

Additional info:
Comment 1 Radek Vokal 2005-08-03 02:06:50 EDT
Sorry, but I don't understand and which exact point the boot hangs. Does it
delay when starting a network interface and is this caused by another daemon?
Can you please attach the bootlog? 
Comment 2 Jonny 2005-08-03 06:34:44 EDT
I do not know what or where the bootlog is? Here is a copy of a post I made to a 
forum which explains all I know:
Having successfully installed Fedora onto a number of desktop computers I 
decided it was time to set up a server.
I have a brand new Fujitsu TX300 and I set up RAID and then Installed Fedora 4 
from 4 CDs. Everything seemed to go fine and I rebooted and made some changes to 
the network settings and the desktop and then rebooted again. On this second 
reboot and subsequent reboots I get stuck at this point:

Enabling Local File Sytem Quotas [OK]
Enabling Swap Space [OK]

It then shows details e.g. CUPS, xinted, sshd, sendmail.
It stops at sendmail and then returns to the 
Enabling Swap Space [OK] screen
and it just sits here until I force a reboot.

Could it be getting stuck when setting up something like sendmail or whatever 
comes next?

My solution to the above question was plugging in the network cable. Immediately 
the machine continues to boot.

This is all I know - I am relatively new to linux and Red Hat so I am no expert.
If you tell me where to find the bootlog I will retrieve it and post it if that 
will help.
Cheers, jonny
Comment 3 Radek Vokal 2005-08-03 07:22:03 EDT
This still doesn't say where exactly it hangs. Does sendmail fail to start?
Check /var/log/boot.log
Comment 4 Jonny 2005-08-03 09:07:52 EDT
my boot log is empty. Maybe it is emptied after each boot?
I cannot give you any more information about the boot sequence as the last thing 
I see is that it tries to start sendmail and then changes back to the 'Enabling 
Swap Space [OK] screen' so I cannot see any more messages. At this point it 
hangs. I think that it is probably the daemon that next starts after sendmail 
which hangs. I have tried this on 2 different machines and after setting the 
host as myserver.mydomain it hangs when booting at this point only if the 
network cable is not plugged in. I don't know if this gives you any more clues 
but obviously I am ignorant of what is happening so if you need me to do 
something I will need instructions.
jonny 
Comment 6 Radek Vokal 2005-08-18 05:48:41 EDT
Ok, I've managed to reproduce this bug on a rawhide machine. The boot hangs
everytime on sendmail. This is the only error I'm seeing in /var/log/messages

root@garfield log# grep "sendmail" messages
Aug 18 11:22:22 garfield sendmail[8902]: sql_select option missing
Aug 18 11:22:22 garfield sendmail[8902]: auxpropfunc error no mechanism available

Sendmail is not configured, just checked to be started at boottime. This should
not cause system to hang. (sendmail-8.13.4-2.i386)
Comment 7 Thomas Woerner 2005-08-18 06:06:11 EDT
Have you removed localhost.localdomain from /etc/hosts completely?
Comment 8 Thomas Woerner 2006-07-14 09:31:01 EDT
This bug entry was in needinfo for some time. Closing due to user inactivity as
"NOT A BUG".

Note You need to log in before you can comment on or make changes to this bug.