Bug 1648768 - Tracker bug for all leases related issues
Summary: Tracker bug for all leases related issues
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
Assignee: Soumya Koduri
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1651323 1655532
TreeView+ depends on / blocked
 
Reported: 2018-11-12 05:08 UTC by Soumya Koduri
Modified: 2019-03-25 16:31 UTC (History)
1 user (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1651323 1655532 (view as bug list)
Environment:
Last Closed: 2019-03-25 16:31:57 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21616 0 None Open lease: Treat unlk request as noop if lease not found 2018-11-17 09:17:54 UTC
Gluster.org Gerrit 21618 0 None Open gfapi: Send fop_attr dict as part of syncop_open 2018-11-17 09:17:04 UTC
Gluster.org Gerrit 21619 0 None Open leases: Fix incorrect inode_ref/unrefs 2018-11-17 09:17:29 UTC
Gluster.org Gerrit 21656 0 None Open gfapi: Offload callback notifications to synctask 2018-11-26 04:20:40 UTC
Gluster.org Gerrit 21737 0 None Open leases: Do not conflict with internal fops 2018-12-03 05:56:03 UTC
Gluster.org Gerrit 21738 0 None Open io-cache: xdata needs to be passed for readv operations 2018-12-04 05:23:57 UTC
Gluster.org Gerrit 21962 0 None Open leases: Reset lease_ctx->timer post deletion 2019-01-07 03:26:06 UTC
Gluster.org Gerrit 21963 0 None Abandoned afr: Use original fop xdata while invoking changelog fsync 2019-02-28 10:44:40 UTC
Gluster.org Gerrit 22286 0 None Open afr: mark changelog_fsync as internal 2019-03-05 09:23:22 UTC
Gluster.org Gerrit 22287 0 None Open leases: Do not process internal fops 2019-03-05 17:49:40 UTC

Description Soumya Koduri 2018-11-12 05:08:48 UTC
Description of problem:

This bug is to track all the issues found with leases testing on glusterfs.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-11-12 06:38:04 UTC
REVIEW: https://review.gluster.org/21616 (lease: Treat unlk request as noop if lease not found) posted (#3) for review on master by soumya k

Comment 2 Worker Ant 2018-11-12 06:39:10 UTC
REVIEW: https://review.gluster.org/21619 (leases: Fix incorrect inode_ref/unrefs) posted (#3) for review on master by soumya k

Comment 3 Worker Ant 2018-11-12 06:41:16 UTC
REVIEW: https://review.gluster.org/21618 (gfapi: Send fop_attr dict as part of syncop_open) posted (#3) for review on master by soumya k

Comment 4 Worker Ant 2018-11-15 14:52:04 UTC
REVIEW: https://review.gluster.org/21656 (gfapi: Offload callback notifications to synctask) posted (#1) for review on master by soumya k

Comment 5 Worker Ant 2018-11-17 09:17:02 UTC
REVIEW: https://review.gluster.org/21618 (gfapi: Send fop_attr dict as part of syncop_open) posted (#8) for review on master by Amar Tumballi

Comment 6 Worker Ant 2018-11-17 09:17:27 UTC
REVIEW: https://review.gluster.org/21619 (leases: Fix incorrect inode_ref/unrefs) posted (#7) for review on master by Amar Tumballi

Comment 7 Worker Ant 2018-11-17 09:17:52 UTC
REVIEW: https://review.gluster.org/21616 (lease: Treat unlk request as noop if lease not found) posted (#7) for review on master by Amar Tumballi

Comment 8 Worker Ant 2018-11-26 04:20:39 UTC
REVIEW: https://review.gluster.org/21656 (gfapi: Offload callback notifications to synctask) posted (#6) for review on master by Amar Tumballi

Comment 9 Worker Ant 2018-11-28 08:49:38 UTC
REVIEW: https://review.gluster.org/21737 (leases: Do not conflict with internal fops) posted (#1) for review on master by soumya k

Comment 10 Worker Ant 2018-11-28 08:50:39 UTC
REVIEW: https://review.gluster.org/21738 (io-cache: xdata needs to be passed for readv operations) posted (#1) for review on master by soumya k

Comment 11 Worker Ant 2018-11-29 16:32:17 UTC
REVISION POSTED: https://review.gluster.org/21751 (gfapi: Offload callback notifications to synctask) posted (#2) for review on release-5 by soumya k

Comment 12 Worker Ant 2018-12-03 05:56:02 UTC
REVIEW: https://review.gluster.org/21737 (leases: Do not conflict with internal fops) posted (#3) for review on master by Amar Tumballi

Comment 13 Worker Ant 2018-12-03 13:17:09 UTC
REVISION POSTED: https://review.gluster.org/21785 (leases: Do not conflict with internal fops) posted (#2) for review on release-5 by soumya k

Comment 14 Worker Ant 2018-12-04 05:23:56 UTC
REVIEW: https://review.gluster.org/21738 (io-cache: xdata needs to be passed for readv operations) posted (#3) for review on master by Raghavendra G

Comment 15 Worker Ant 2018-12-30 13:55:04 UTC
REVIEW: https://review.gluster.org/21962 (leases: Reset lease_ctx->timer post deletion) posted (#1) for review on master by soumya k

Comment 16 Worker Ant 2018-12-30 13:56:20 UTC
REVIEW: https://review.gluster.org/21963 (afr: Use local->xdata_req while invoking changelog fsync) posted (#1) for review on master by soumya k

Comment 17 Worker Ant 2019-01-07 03:26:05 UTC
REVIEW: https://review.gluster.org/21962 (leases: Reset lease_ctx->timer post deletion) posted (#3) for review on master by Amar Tumballi

Comment 18 Worker Ant 2019-02-28 09:57:30 UTC
REVIEW: https://review.gluster.org/22286 (afr: mark changelog_fsync as internal) posted (#1) for review on master by soumya k

Comment 19 Worker Ant 2019-02-28 09:58:45 UTC
REVIEW: https://review.gluster.org/22287 (leases: Do not process internal fops) posted (#1) for review on master by soumya k

Comment 20 Worker Ant 2019-03-05 09:23:23 UTC
REVIEW: https://review.gluster.org/22286 (afr: mark changelog_fsync as internal) merged (#4) on master by Ravishankar N

Comment 21 Worker Ant 2019-03-05 17:49:41 UTC
REVIEW: https://review.gluster.org/22287 (leases: Do not process internal fops) merged (#4) on master by Amar Tumballi

Comment 22 Shyamsundar 2019-03-25 16:31:57 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.