Bug 1648818 - Mouse scroll doesn't work in xfce-settings-manager
Summary: Mouse scroll doesn't work in xfce-settings-manager
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-settings
Version: 29
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-12 08:06 UTC by Aaron Lu
Modified: 2019-01-06 02:21 UTC (History)
2 users (show)

Fixed In Version: xfce4-settings-4.13.5-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-06 02:21:46 UTC
Type: Bug


Attachments (Terms of Use)

Description Aaron Lu 2018-11-12 08:06:45 UTC
Description of problem:
Apology if I chose the wrong category.

Mouse scroll doesn't work in windows like the 'select style' window of the Appearance window.

Version-Release number of selected component (if applicable):
greybird-xfce4-notifyd-theme-3.22.8-2.fc29.noarch
xfce4-panel-4.13.3-20.fc29.x86_64
xfce4-session-4.13.1-20.fc29.x86_64
xfce4-terminal-0.8.7.4-20.fc29.x86_64
xfce4-notifyd-0.4.2-20.fc29.x86_64
xfce4-screenshooter-1.9.3-20.fc29.x86_64
xfce4-about-4.13.4-20.fc29.x86_64
im-chooser-xfce-1.7.1-6.fc29.x86_64
xfce4-places-plugin-1.7.0-20.fc29.x86_64
xfce-polkit-0.2-13.fc29.x86_64
xfce4-power-manager-1.6.1-20.fc29.x86_64
imsettings-xfce-1.7.3-6.fc29.x86_64
libxfce4util-4.13.2-20.fc29.x86_64
xfce4-appfinder-4.13.1-1.fc29.x86_64
gtk-xfce-engine-3.2.0-8.fc29.x86_64
xfce4-settings-4.13.5-1.fc29.x86_64
xfce4-session-engines-4.13.1-20.fc29.x86_64
xfce4-datetime-plugin-0.7.0-20.fc29.x86_64
xfce4-pulseaudio-plugin-0.4.1-21.fc29.x86_64
xfce4-screenshooter-plugin-1.9.3-20.fc29.x86_64
xfce4-whiskermenu-plugin-2.3.0-1.fc29.x86_64
libxfce4ui-4.13.4-20.fc29.x86_64


How reproducible:
Always

Steps to Reproduce:
1. login to xfce
2. start setting manager
3. choose Appearance
4. Scroll the style list using mouse

Actual results:
nothing happened

Expected results:
list scroll

Additional info:
Mouse scroll works elsewhere like firefox, file manager, etc., including the settings window itself. But once clicking into items like Appearance, Window Manager, the style list won't scroll with mouse.

Comment 1 Kevin Fenzi 2018-11-15 21:33:45 UTC
Are you willing to file this upstream ( bugzilla.xfce.org ) or would you like me to do so?

And are you using any of the scrolling options? vertical, two finger, natural, etc?

Comment 2 Aaron Lu 2018-11-16 02:27:50 UTC
(In reply to Kevin Fenzi from comment #1)
> Are you willing to file this upstream ( bugzilla.xfce.org ) or would you
> like me to do so?

Thank you Kevin for the reply.
I can do the filing upstream.

> And are you using any of the scrolling options? vertical, two finger,
> natural, etc?

I'm using a mouse, not a touchpad.
I don't see those settings in 'Mouse and Touchpad' so I guess the answer is no here :-)

Comment 3 Aaron Lu 2018-11-16 02:35:06 UTC
Filed upstream:
https://bugzilla.xfce.org/show_bug.cgi?id=14879

Comment 4 Mukundan Ragavan 2018-11-16 23:05:50 UTC
There seems to be a patch for it. Do you want a test build with the patch?

Comment 5 Aaron Lu 2018-11-17 01:31:17 UTC
(In reply to Mukundan Ragavan from comment #4)
> There seems to be a patch for it. Do you want a test build with the patch?

That would be great, thanks!

Comment 6 Fedora Update System 2018-12-20 14:28:38 UTC
xfce4-settings-4.13.5-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-332d9716ff

Comment 7 Fedora Update System 2018-12-21 21:06:07 UTC
xfce4-settings-4.13.5-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-332d9716ff

Comment 8 Fedora Update System 2019-01-06 02:21:46 UTC
xfce4-settings-4.13.5-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.