Bug 1648825 - Split and update smc-fonts to match upstream release
Summary: Split and update smc-fonts to match upstream release
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: smc-fonts
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: vishal vijayraghavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-12 08:34 UTC by Rajeesh
Modified: 2019-02-26 08:20 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-22 06:41:16 UTC


Attachments (Terms of Use)

Description Rajeesh 2018-11-12 08:34:51 UTC
Description of problem:
We haven't updated smc-fonts in 4 years in Fedora. A lot of updates and fixes were made and a new font was added by upstream in the meantime. With that, a lot of discussions on how to manage the releases of fonts also took place, because by then each font was being updated differently and was getting a different version number.

Upstream moved to Gitlab instead of Savannah and each font with its own version number is hosted in individual repository now, see https://gitlab.com/smc/fonts. Fedora can no longer depend on the existing packaging mechanism of single tarball and single makefile, as some fonts use different build tools (e.g. Manjari uses UFO+Fontmake) as well.

I've discussed with pravins and he suggests to split the fonts and open a bug for that.

Version-Release number of selected component (if applicable):
6.1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Nicolas Mailhot 2018-11-12 09:53:18 UTC
That would be awfully nice.

Please note however that I will push a font packaging macro rewrite sometime this month in devel.

Comment 2 Pravin Satpute 2018-11-13 11:51:06 UTC
Thanks Rajeesh for reporting bug. As we discussed, we were having same problem with lohit-fonts packages, Now each font is separate package and maintenance is easy.

Comment 3 vishal vijayraghavan 2019-02-22 06:41:16 UTC
Splitting of smc-fonts into individual font package is completed and available for use in f30+

Comment 4 Rajeesh 2019-02-22 09:09:50 UTC
Thanks Vishal!

Could you share the pagure/packages URL to the new packages repo?

Comment 7 Rajeesh 2019-02-23 09:09:35 UTC
(In reply to vishal vijayraghavan from comment #5)
> https://src.fedoraproject.org/rpms/smc-anjalioldlipi-fonts
> https://src.fedoraproject.org/rpms/smc-dyuthi-fonts
> https://src.fedoraproject.org/rpms/smc-meera-fonts
> https://src.fedoraproject.org/rpms/smc-rachana-fonts
> https://src.fedoraproject.org/rpms/smc-raghumalayalamsans-fonts
> https://src.fedoraproject.org/rpms/smc-suruma-fonts

Just a thought.
The font packaging guidelines say we SHOULD build from source if possible [1].
Any particular reason not to follow that? (The upstream Makefile is not very well suited for Fedora, but I can engage with upstream if anything could be improved).

[1] https://docs.fedoraproject.org/en-US/packaging-guidelines/FontsPolicy/#_building_from_sources

Comment 8 Nicolas Mailhot 2019-02-24 15:49:44 UTC
If you can build from sources please do so. That's the only way to make sure our font building infra is sane and we will be able to use it the day someone needs a fix in the font files and upstream is busy somewhere else. (and that also makes sure Fedora is something upstream can rely on should it need to).

DejaVu for example builds fine from source in Fedora, that's the result of a cooperation between us and the font project to fix the required Makefile parts.

Comment 9 vishal vijayraghavan 2019-02-25 11:59:48 UTC
Thank you Rajeesh and Nicolas for bringing up this topic.
Have rebuild all fonts from sources except smc-suruma-fonts because of the missing file and also have reported it in upstream[1]

[1] https://gitlab.com/smc/fonts/suruma/issues/4

Comment 10 Rajeesh 2019-02-26 08:20:52 UTC
(In reply to vishal vijayraghavan from comment #9)
> Thank you Rajeesh and Nicolas for bringing up this topic.
> Have rebuild all fonts from sources except smc-suruma-fonts because of the
> missing file and also have reported it in upstream[1]
> 
> [1] https://gitlab.com/smc/fonts/suruma/issues/4

I've just fixed the issue with Suruma and tagged a new release.


Note You need to log in before you can comment on or make changes to this bug.