Bug 164883 - REPLACED files disappear when removing older version of a package
REPLACED files disappear when removing older version of a package
Status: CLOSED DUPLICATE of bug 140055
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-02 05:33 EDT by Bill Crawford
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 13:50:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2005-08-02 05:33:40 EDT
Description of problem:
After installing a newer package with --replacefiles, and then removing an older
version with the same version (but different release), /usr/share/doc/xxx is
missing.

Version-Release number of selected component (if applicable):
rpm-4.4.2-3
libcdio-0.75-1.fc5
libcdio-0.75-4.fc5

How reproducible:
install libcdio-0.75-4.fc5 with --replacefiles
remove libcdio-0.75-1
run rpm -V libcdio

Actual results:
[root@pikachu ~]# rpm -V libcdio-0.75-4.fc5
missing     /usr/share/doc/libcdio-0.75
missing   d /usr/share/doc/libcdio-0.75/AUTHORS
missing   d /usr/share/doc/libcdio-0.75/COPYING
missing   d /usr/share/doc/libcdio-0.75/NEWS
missing   d /usr/share/doc/libcdio-0.75/README
missing   d /usr/share/doc/libcdio-0.75/README.libcdio
missing   d /usr/share/doc/libcdio-0.75/THANKS
missing   d /usr/share/doc/libcdio-0.75/TODO
[root@pikachu ~] 

Expected results:
[root@pikachu ~]# rpm -V libcdio-0.75-4.fc5
[root@pikachu ~]#
Comment 1 Paul Nasrat 2005-11-28 13:50:30 EST

*** This bug has been marked as a duplicate of 140055 ***

Note You need to log in before you can comment on or make changes to this bug.