Bug 164884 - It's impossible to add network printer with hplip backend
It's impossible to add network printer with hplip backend
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-02 05:35 EDT by Vaclav "sHINOBI" Misek
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-13 10:37:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vaclav "sHINOBI" Misek 2005-08-02 05:35:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
When I try to create a new locally connected device (hp:/net/hp_color_LaserJet_3550?ip=10.0.0.10), there's an error "hp:/net/hp_color_LaserJet_3550?ip=10.0.0.10 does not exist, or is not writable". Networked JetDirect queue type is not working as well.
It works in text mode selecting local printer device -> custom and setting the hp:/net/hp_color_LaserJet_3550?ip=10.0.0.10 parameter.


Version-Release number of selected component (if applicable):
system-config-printer-0.6.138-1-gui

How reproducible:
Always

Steps to Reproduce:
1. start system-config-printer-gui
2. add custom device with previously mentioned parameters
3.
  

Actual Results:  It should work the same way in system-config-printer-gui as in the text version.

Additional info:
Comment 1 Tim Waugh 2005-08-02 07:09:44 EDT
What does 'rpm -q system-config-printer' say?  I'm a little confused, because
you seem to be indicating that you are running the Fedora Core development
version of that package, rather than the FC4 update.
Comment 2 Vaclav "sHINOBI" Misek 2005-08-02 08:22:46 EDT
rpm -q shows system-config-printer-0.6.138-1. It's my mistake, I tried to use
the latest version of SRPMS from rawhide (because the normal FC4 update produced
even worse results for me) and I recompiled it for FC4. I forgot to mention it.
I'm sorry :-(.
Comment 3 Tim Waugh 2005-08-02 08:29:23 EDT
Well, use the update.  If that has bugs, you need to report *them*.
Comment 4 Vaclav "sHINOBI" Misek 2005-08-03 08:16:04 EDT
OK, i tried to downgrade to system-config-printer-0.6.131.3-1 and the behaviour
is the same.
Comment 5 Tim Waugh 2005-08-03 08:19:11 EDT
In the original report you said:

> there's an error "hp:/net/hp_color_LaserJet_3550?ip=10.0.0.10 does not exist,
> or is not writable"

Where does this error appear?
Comment 6 Vaclav "sHINOBI" Misek 2005-08-03 08:44:42 EDT
When I try to add new custom device (under locally connected queue type). There
is requester Enter the device you would like to use, so after filling that
device this error appears. It's possible to add this device with the same steps
in the text mode.
Comment 7 Tim Waugh 2005-08-03 09:15:05 EDT
"Custom device" is for things like /dev/ttyS1 or whatever, which is the reason
for that check.

What does 'lpinfo -v' say?
Comment 8 Vaclav "sHINOBI" Misek 2005-08-03 09:39:30 EDT
Interesting, it seems to be missing (btw the printer is working without probs
and is seen in hp-toolbox with DeviceURI
hp:/net/hp_color_LaserJet_3550?ip=10.0.0.10).

# lpinfo -v
network socket
direct hal
direct hp:/no_device_found
network http
network ipp
network lpd
direct parallel:/dev/lp0
direct scsi
serial serial:/dev/ttyS0?baud=115200
serial serial:/dev/ttyS1?baud=115200
serial serial:/dev/ttyS2?baud=115200
serial serial:/dev/ttyS3?baud=115200
serial serial:/dev/ttyS4?baud=115200
serial serial:/dev/ttyS5?baud=115200
serial serial:/dev/ttyS6?baud=115200
serial serial:/dev/ttyS7?baud=115200
serial serial:/dev/ttyS8?baud=115200
serial serial:/dev/ttyS9?baud=115200
serial serial:/dev/ttyS10?baud=115200
serial serial:/dev/ttyS11?baud=115200
serial serial:/dev/ttyS12?baud=115200
serial serial:/dev/ttyS13?baud=115200
serial serial:/dev/ttyS14?baud=115200
serial serial:/dev/ttyS15?baud=115200
serial serial:/dev/ttyS16?baud=115200
serial serial:/dev/ttyS17?baud=115200
serial serial:/dev/ttyS18?baud=115200
serial serial:/dev/ttyS19?baud=115200
serial serial:/dev/ttyS20?baud=115200
serial serial:/dev/ttyS21?baud=115200
serial serial:/dev/ttyS22?baud=115200
serial serial:/dev/ttyS23?baud=115200
serial serial:/dev/ttyS24?baud=115200
serial serial:/dev/ttyS25?baud=115200
serial serial:/dev/ttyS26?baud=115200
serial serial:/dev/ttyS27?baud=115200
serial serial:/dev/ttyS28?baud=115200
serial serial:/dev/ttyS29?baud=115200
serial serial:/dev/ttyS30?baud=115200
serial serial:/dev/ttyS31?baud=115200
serial serial:/dev/ttyS32?baud=115200
serial serial:/dev/ttyS33?baud=115200
serial serial:/dev/ttyS34?baud=115200
serial serial:/dev/ttyS35?baud=115200
serial serial:/dev/ttyS36?baud=115200
serial serial:/dev/ttyS37?baud=115200
serial serial:/dev/ttyS38?baud=115200
serial serial:/dev/ttyS39?baud=115200
serial serial:/dev/ttyS40?baud=115200
serial serial:/dev/ttyS41?baud=115200
serial serial:/dev/ttyS42?baud=115200
serial serial:/dev/ttyS43?baud=115200
serial serial:/dev/ttyS44?baud=115200
serial serial:/dev/ttyS45?baud=115200
serial serial:/dev/ttyS46?baud=115200
serial serial:/dev/ttyS47?baud=115200
serial serial:/dev/ttyS48?baud=115200
serial serial:/dev/ttyS49?baud=115200
serial serial:/dev/ttyS50?baud=115200
serial serial:/dev/ttyS51?baud=115200
serial serial:/dev/ttyS52?baud=115200
serial serial:/dev/ttyS53?baud=115200
serial serial:/dev/ttyS54?baud=115200
serial serial:/dev/ttyS55?baud=115200
serial serial:/dev/ttyS56?baud=115200
serial serial:/dev/ttyS57?baud=115200
serial serial:/dev/ttyS58?baud=115200
serial serial:/dev/ttyS59?baud=115200
serial serial:/dev/ttyS60?baud=115200
serial serial:/dev/ttyS61?baud=115200
serial serial:/dev/ttyS62?baud=115200
serial serial:/dev/ttyS63?baud=115200
serial serial:/dev/ttyS64?baud=115200
serial serial:/dev/ttyS65?baud=115200
serial serial:/dev/ttyS66?baud=115200
serial serial:/dev/ttyS67?baud=115200
serial serial:/dev/ttyS68?baud=115200
serial serial:/dev/ttyS69?baud=115200
serial serial:/dev/ttyS70?baud=115200
serial serial:/dev/ttyS71?baud=115200
serial serial:/dev/ttyS72?baud=115200
serial serial:/dev/ttyS73?baud=115200
serial serial:/dev/ttyS74?baud=115200
serial serial:/dev/ttyS75?baud=115200
direct usb:/dev/usb/lp0
direct usb:/dev/usb/lp1
direct usb:/dev/usb/lp2
direct usb:/dev/usb/lp3
direct usb:/dev/usb/lp4
direct usb:/dev/usb/lp5
direct usb:/dev/usb/lp6
direct usb:/dev/usb/lp7
direct usb:/dev/usb/lp8
direct usb:/dev/usb/lp9
direct usb:/dev/usb/lp10
direct usb:/dev/usb/lp11
direct usb:/dev/usb/lp12
direct usb:/dev/usb/lp13
direct usb:/dev/usb/lp14
direct usb:/dev/usb/lp15
network smb
Comment 9 Tim Waugh 2005-08-03 10:08:59 EDT
(It will be shown in hp-toolbox if you have added that queue using another
method, perhaps http://localhost:631/.  Not relevant.)

Can you edit /etc/hp/hplip.conf so that 'jdprobe=1'?  Then 'service hplip
restart' and 'service cups restart'.

What does 'lpinfo -v' say then?

I imagine it still does not find this device, due to a problem I found myself
while investigating this report earlier:

http://sourceforge.net/mailarchive/forum.php?thread_id=7882198&forum_id=5841
Comment 10 Vaclav "sHINOBI" Misek 2005-08-03 10:15:06 EDT
Yes, the output is the same. I read somewhere that hplip is unable to autodetect
network printers, what should be related to this problem.
Comment 11 Tim Waugh 2005-08-03 10:16:50 EDT
No, it autodetects them just fine (tested here).  The backend uses the wrong
format to describe them to CUPS, that's all.
Comment 12 Matt Emmett 2005-08-11 15:08:34 EDT
No, their are printers that it does not detect.  In the readme for the source it
says they are aware of the problem and give directions for hp-makeuri.  I have
an Officejet 7300.  It is not found with hp-probe -bnet, and I can't find anyway
to add it via system-config-printer.  I am using following packages:
hpijs-0.9.4-1.1, hplip-0.9.4-1.1, system-config-printer-0.6.131.3-1, and
system-config-printer-gui-0.6.131.3-1.  After doing a hp-makeuri I am able to
add the device via the cups admin page, and then I can print, scan, and use the
photo card.
Comment 13 Tim Waugh 2006-12-13 10:37:25 EST
Arbitrary URIs can now be specified in FC6.

Note You need to log in before you can comment on or make changes to this bug.