Bug 1648893 - statedump doesn't contain information about newer mempools
Summary: statedump doesn't contain information about newer mempools
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: core
Version: rhgs-3.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: RHGS 3.4.z Batch Update 3
Assignee: Sunny Kumar
QA Contact: Sayalee
URL:
Whiteboard:
Depends On:
Blocks: RHGS34MemoryLeak 1649191
TreeView+ depends on / blocked
 
Reported: 2018-11-12 11:56 UTC by Raghavendra G
Modified: 2019-02-06 12:05 UTC (History)
14 users (show)

Fixed In Version: glusterfs-3.12.2-34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-04 07:41:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github gluster glusterfs issues 307 0 None None None 2018-12-31 02:57:06 UTC
Red Hat Product Errata RHBA-2019:0263 0 None None None 2019-02-04 07:41:37 UTC

Description Raghavendra G 2018-11-12 11:56:32 UTC
Description of problem:

We have moved to newer implementation of mem-pools. But statedump doesn't print the information about them. Github issue [1] captures upstream effort on this. But preliminary reading shows the work still has some parts to be completed. So, the effort includes:

* backporting https://review.gluster.org/18076
* reviewing whether the information printed by above patch is complete from the perspective of debugging memory consumption issues.

[1] https://github.com/gluster/glusterfs/issues/307


Version-Release number of selected component (if applicable):
3.4.0

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Amar Tumballi 2018-11-19 05:09:05 UTC
Patch is already available upstream.

Comment 5 Raghavendra G 2018-11-26 14:23:32 UTC
(In reply to Amar Tumballi from comment #4)
> Patch is already available upstream.

If you are speaking about https://review.gluster.org/18076, we still need to evaluate whether it covers all aspects of newer memory pools. So, the work may not be complete

Comment 9 Raghavendra G 2018-12-11 05:09:27 UTC
https://review.gluster.org/#/c/glusterfs/+/18075/ is needed too.

Comment 10 Raghavendra G 2018-12-11 05:23:05 UTC
commit msg of one of patches [1] say - This only captures the information from 'struct mem_pool', and not from the global 'struct mem_pool_shared' or the pool_sweeper thread. The current details help with detecting memory leaks.


so we need to find out what is left out if we don't dump those fields and preferably add those two fields if important. 

[1] https://review.gluster.org/18076

Comment 32 Sayalee 2019-01-08 11:33:11 UTC
Based on the points discussed in #comment28,#comment30 and #comment31 , moving this bug to verified.

Comment 34 errata-xmlrpc 2019-02-04 07:41:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0263


Note You need to log in before you can comment on or make changes to this bug.