Bug 1648923 - gfapi: fix bad dict setting of lease-id
Summary: gfapi: fix bad dict setting of lease-id
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: 5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-12 13:17 UTC by Kinglong Mee
Modified: 2018-11-29 15:21 UTC (History)
3 users (show)

Fixed In Version: glusterfs-5.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1647651
Environment:
Last Closed: 2018-11-29 15:21:29 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21586 0 None None None 2018-11-12 13:17:14 UTC
Gluster.org Gerrit 21625 0 None Open gfapi: fix bad dict setting of lease-id 2018-11-13 20:45:41 UTC

Description Kinglong Mee 2018-11-12 13:17:14 UTC
+++ This bug was initially created as a clone of Bug #1647651 +++

Description of problem:

lease_id is a 16 bits opaque data, copying it by gf_strdup is wrong.

Invalid read of size 2
   at 0x483FA2F: memmove (vg_replace_strmem.c:1270)
   by 0xE2EF6FB: ??? (in /usr/lib64/libtirpc.so.3.0.0)
   by 0xE2EE047: xdr_opaque (in /usr/lib64/libtirpc.so.3.0.0)
   by 0x107A97DC: xdr_gfx_value (glusterfs4-xdr.c:207)
   by 0x107A98C0: xdr_gfx_dict_pair (glusterfs4-xdr.c:321)
   by 0xE2EF35E: xdr_array (in /usr/lib64/libtirpc.so.3.0.0)
   by 0x107A9A89: xdr_gfx_dict (glusterfs4-xdr.c:335)
   by 0x107AA97B: xdr_gfx_write_req (glusterfs4-xdr.c:897)
   by 0x107A181E: xdr_serialize_generic (xdr-generic.c:25)
   by 0x231044A2: client_submit_request (client.c:205)
   by 0x2314D3C1: client4_0_writev (client-rpc-fops_v2.c:3863)
   by 0x230FD5FA: client_writev (client.c:956)
 Address 0xad659e18 is 72 bytes inside a block of size 73 alloc'd
   at 0x483880B: malloc (vg_replace_malloc.c:299)
   by 0x106BA7EC: __gf_malloc (mem-pool.c:136)
   by 0x1064521E: gf_strndup (mem-pool.h:166)
   by 0x1064521E: gf_strdup (mem-pool.h:183)
   by 0x1064521E: get_fop_attr_thrd_key (glfs.c:627)
   by 0x1064D8E9: glfs_pwritev@@GFAPI_3.4.0 (glfs-fops.c:1154)
   by 0x10610C0C: glusterfs_write2 (handle.c:2092)
   by 0x54D30C: mdcache_write2 (mdcache_file.c:647)
   by 0x48A3FC: nfs4_write (nfs4_op_write.c:459)
   by 0x48A44D: nfs4_op_write (nfs4_op_write.c:487)
   by 0x4634F5: nfs4_Compound (nfs4_Compound.c:947)
   by 0x460155: nfs_rpc_process_request (nfs_worker_thread.c:1329)
   by 0x4608A3: nfs_rpc_valid_NFS (nfs_worker_thread.c:1539)
   by 0x488F12F: svc_vc_decode (svc_vc.c:825)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2018-11-07 22:25:08 EST ---

REVIEW: https://review.gluster.org/21586 (gfapi: fix bad dict setting of lease-id) posted (#2) for review on master by Kinglong Mee

--- Additional comment from Worker Ant on 2018-11-08 10:12:52 EST ---

REVIEW: https://review.gluster.org/21586 (gfapi: fix bad dict setting of lease-id) posted (#3) for review on master by soumya k

--- Additional comment from Soumya Koduri on 2018-11-12 03:20:34 EST ---

Could you please backport this fix to release-5 and release-4 branches as well. Thanks!

Comment 1 Worker Ant 2018-11-12 13:38:49 UTC
REVIEW: https://review.gluster.org/21625 (gfapi: fix bad dict setting of lease-id) posted (#1) for review on release-5 by Kinglong Mee

Comment 2 Worker Ant 2018-11-13 20:45:40 UTC
REVIEW: https://review.gluster.org/21625 (gfapi: fix bad dict setting of lease-id) posted (#1) for review on release-5 by Kinglong Mee

Comment 3 Shyamsundar 2018-11-29 15:21:29 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.1, please open a new bug report.

glusterfs-5.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-November/000116.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.