Bug 1648972 - OpenShift on Openstack does not create load balancers
Summary: OpenShift on Openstack does not create load balancers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.11.z
Assignee: Yossi Boaron
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-12 15:45 UTC by Ryan Cook
Modified: 2019-12-23 05:56 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-23 19:56:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift openshift-ansible pull 10763 0 None closed Extend Openstack cloud provider LB parameters 2020-09-18 15:11:24 UTC
Red Hat Product Errata RHBA-2019:1753 0 None None None 2019-07-23 19:56:35 UTC

Description Ryan Cook 2018-11-12 15:45:14 UTC
Description of problem: OpenStack cloud provider cannot create an LB service with octavia


Version-Release number of selected component (if applicable):
3.11.16-1 openshit 
openstack 13

How reproducible: Create application and the expose service as a load balancer


Steps to Reproduce:
1. oc new-project bz
2. oc new-app centos/ruby-25-centos7~https://github.com/sclorg/ruby-ex.git
3. oc expose dc ruby-ex --name='ruby-ex-external' --type='LoadBalancer'


Actual results: 
37s       4         ruby-ex-external.15666ad273d44085   Service             Warning   CreatingLoadBalancerFailed   service-controller   Error creating load balancer (will retry): failed to ensure load balancer for service bz/ruby-ex-external: error creating loadbalancer a9dbc5b34e69111e8bc0dfa163e5d33b: error creating loadbalancer {a9dbc5b34e69111e8bc0dfa163e5d33b Kubernetes external service a9dbc5b34e69111e8bc0dfa163e5d33b 4b398208-529e-4fe6-a0cb-8303bb8a0524    <nil>  }: Resource not found



Expected results:
load balancer created with octavia


Additional info: cloud provider does not create load balancers in the same way that aws, azure, gce do

Comment 1 Ryan Cook 2018-11-14 15:08:44 UTC
we are using the standard OpenShift SDN rather than kuryr

Comment 5 Ryan Cook 2018-11-23 02:09:06 UTC
The following options should be added to the OSP cloud provider configuration if a customer would like to be able to use a load balancer from within OSP

<values have been modified to not reflect current deployment values>
[LoadBalancer]
subnet-id = 4b398208-529e-4fe6-a0cb-8606cc8a0524
use-octavia = true
subnet-id = 4b398208-529e-4fe6-a0cb-86068cca0524
floating-network-id = 56d2e900-c328-33ab-928e-43503b3f4187

Comment 8 Jan Chaloupka 2018-11-23 11:23:52 UTC
> The following options should be added to the OSP cloud provider configuration if a customer would like to be able to use a load balancer from within OSP

Ryan, are you saying we need to extend the code and introduce new configuration option? Or, the option is already there and only OpenStack cloud config file needs to be updated?

Comment 9 Josep 'Pep' Turro Mauri 2018-11-23 13:22:33 UTC
(In reply to Jan Chaloupka from comment #8)
> Ryan, are you saying we need to extend the code and introduce new
> configuration option? Or, the option is already there and only OpenStack
> cloud config file needs to be updated?

The openstack cloud provider config does support these options that we had to add in order for LoadBalancer type services to work, but the installer only manages the subnet-id option.

Here's a proposed PR to add use-octavia and floating-network-id as additional options:

https://github.com/openshift/openshift-ansible/pull/10758

I guess we should move this bz to the installer component, right?

Comment 10 Jan Chaloupka 2018-11-23 13:26:35 UTC
Thanks for clarification. Yes, this needs to be fixed in the installer. Moving to the component.

Comment 12 weiwei jiang 2019-01-25 06:48:21 UTC
OCP qe side have no OSP with octavia enable for testing, so change qa contact to others

Comment 14 GenadiC 2019-07-08 09:06:13 UTC
Verified on OCP_98

Comment 16 errata-xmlrpc 2019-07-23 19:56:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1753


Note You need to log in before you can comment on or make changes to this bug.