Bug 164898 - lam should be built with --with-trillium instead of --enable-trilllium
lam should be built with --with-trillium instead of --enable-trilllium
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lam (Show other bugs)
4
All Linux
medium Severity low
: ---
: ---
Assigned To: Jason Vas Dias
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-02 09:12 EDT by Maximiliano Bertacchini
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 7.1.1-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 09:07:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Maximiliano Bertacchini 2005-08-02 09:12:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
I noticed that trillium support is disabled in lam although the "lam.spec" changelog states that it should be enabled (Fri Dec 05 2003). The reason is that spec configure options include the "--enable-trillium" option (which is not supported by the configure script) instead of "--with-trillium" (the correct option).

Trillium support is needed by certain third party products that interact with the lower layer of LAM/MPI.

Version-Release number of selected component (if applicable):
lam-7.1.1-6.FC3

How reproducible:
Always

Steps to Reproduce:
1.Download xmtv from lam homepage and extract into any directory
2.Run ./configure


Actual Results:  ./configure script aborts showing the next message:

configure: WARNING: Can not find Trillium header files.
configure: WARNING: LAM/MPI must be configured with the '--with-trillium'
configure: WARNING: option in order to build this application
configure: error: cannot continue -- cannot find Trillium header files


Expected Results:  The ./configure script should find the trillium headers and finish successfully.

Additional info:

I rebuilt the lam-7.1.1-6.FC3.src.rpm replacing "--enable-trillium" with "--with-trillium" in the lam.spec file. Everything worked fine and I got a lam-7.1.1-6.FC3.rpm package with trillium support, which I installed. Then xmtv could be built from source with no problems.
Comment 1 Jason Vas Dias 2005-08-09 17:18:48 EDT
This is now fixed with lam-7.1.1-7.FC3 in today's FC3 update.
Comment 2 Maximiliano Bertacchini 2005-08-10 08:26:40 EDT
Ok, lam-7.1.1-7.FC3 now works fine as expected.
I noticed this same bug applies to lam-7.1.1-6.FC4, and I'm not sure how to
proceed. Should I report it as a new bug or what?
Thanks...

(In reply to comment #1)
> This is now fixed with lam-7.1.1-7.FC3 in today's FC3 update.
> 

Comment 3 Jason Vas Dias 2005-08-13 13:33:07 EDT
lam is now updated to 7.1.1-7 in FC4, built with the 'with-trillium' option.
Comment 4 Walter Justen 2005-08-19 09:07:11 EDT
Thanks for the bug report. This particular bug was fixed and a update package
was published for download. Please feel free to report any further bugs you find.

Note You need to log in before you can comment on or make changes to this bug.