Bug 164899 - gstreamer cannot be rebuild on current rawhide system
gstreamer cannot be rebuild on current rawhide system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-02 09:25 EDT by Karsten Hopp
Modified: 2013-03-13 00:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-05 01:41:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2005-08-02 09:25:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050729 Fedora/1.1-0.2.5.deerpark.alpha2 Firefox/1.0+

Description of problem:
gstreamer has a hardcoded path /usr/share/sgml/docbook/xml-dtd-4.2-1.0-26/docbookx.dtd in its docs, but we have /usr/share/sgml/docbook/xml-dtd-4.2-1.0-27/docbookx.dtd. 
Rebuilds therefore fail with the following error:
Working on: /home/build/rebuild/build/gstreamer-0.8.10-1.src.rpm/gstreamer-0.8.10/docs/faq/build/faq.xml
jade:/home/build/rebuild/build/gstreamer-0.8.10-1.src.rpm/gstreamer-0.8.10/docs/faq/build/faq.xml:24:0:E: cannot open "/usr/share/sgml/docbook/xml-dtd-4.2-1.0-26/docbookx.dtd" (No such file or directory)
jade:/home/build/rebuild/build/gstreamer-0.8.10-1.src.rpm/gstreamer-0.8.10/docs/faq/build/faq.xml:24:0:E: DTD did not contain element declaration for document type name
jade:/home/build/rebuild/build/gstreamer-0.8.10-1.src.rpm/gstreamer-0.8.10/docs/faq/build/faq.xml:26:15:E: there is no attribute "class"
jade:/home/build/rebuild/build/gstreamer-0.8.10-1.src.rpm/gstreamer-0.8.10/docs/faq/build/faq.xml:26:24:E: there is no attribute "id"
jade:/home/build/rebuild/build/gstreamer-0.8.10-1.src.rpm/gstreamer-0.8.10/docs/faq/build/faq.xml:26:31:E: element "article" undefined
jade:/home/build/rebuild/build/gstreamer-0.8.10-1.src.rpm/gstreamer-0.8.10/docs/faq/build/faq.xml:27:14:E: element "articleinfo" undefined
jade:/home/build/rebuild/build/gstreamer-0.8.10-1.src.rpm/gstreamer-0.8.10/docs/faq/build/faq.xml:28:10:E: element "title" undefined
jade:/home/build/rebuild/build/gstreamer-0.8.10-1.src.rpm/gstreamer-0.8.10/docs/faq/build/faq.xml:29:13:E: element "abstract" undefined
.....



Version-Release number of selected component (if applicable):
gstreamer-0.8.10-1

How reproducible:
Always

Steps to Reproduce:
1. rebuild gstreamer-0.8.10-1 on a current rawhide system
2.
3.
  

Additional info:

This should be fixed before the next massrebuild
Comment 1 Matthias Clasen 2006-02-05 01:41:10 EST
Probably no longer relevant, since several new versions of gstreamer have
successfully been built since this report was opened.

Note You need to log in before you can comment on or make changes to this bug.