Bug 1649 - Upgrade 5.8.6 -> 5.9 failed
Upgrade 5.8.6 -> 5.9 failed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-21 12:09 EST by Pekka Pietikäinen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-25 21:12:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Pietikäinen 1999-03-21 12:09:37 EST
When doing a CD upgrade from 5.8.6 to 5.9 the installer
found garbage names for my partitions (looked like
it might be a bad pointer or similar) making upgrading
impossible.

The amount of partitions was correct and a normal install
works fine.

The upgrade was attempted to a SCSI disk (aic7880) from IDE
cdrom. One special feature of the disk is that it was
partitioned under a different scsi controller, so fdisk
reports errors like

/dev/sdb1             1      102   103849+  83  Linux native
Partition 1 does not end on cylinder boundary:
     phys=(24, 133, 62) should be (24, 63, 32)
/dev/sdb2           102      167    66464   82  Linux swap
Partition 2 does not end on cylinder boundary:
     phys=(40, 133, 62) should be (40, 63, 32)
/dev/sdb3           167      820   668794   83  Linux native
Partition 3 does not end on cylinder boundary:
     phys=(201, 133, 62) should be (201, 63, 32)
/dev/sdb4           820     4134  3393818    5  Extended
Partition 4 does not end on cylinder boundary:
     phys=(1018, 133, 62) should be (1018, 63, 32)
/dev/sdb5           820     2869  2097769+  83  Linux native
/dev/sdb6          2869     4134  1296047+  83  Linux native

because the geometry used is different, but the disk has
worked like that without problems for a year or so.
Comment 1 Matt Wilson 1999-03-25 21:12:59 EST
fixed.

Note You need to log in before you can comment on or make changes to this bug.